summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-04-10 19:31:28 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-04-10 22:02:01 +0200
commitc9269d95522eedd2c9d8ea7d9fca808c3a4cf0f5 (patch)
tree4eb1873d2a7ca4a5e74f4927dd51b94d839cd02b
parentapp-emacs/swiper: new package; add version 0.13.4 (diff)
downloadgentoo-c9269d95522eedd2c9d8ea7d9fca808c3a4cf0f5.tar.gz
gentoo-c9269d95522eedd2c9d8ea7d9fca808c3a4cf0f5.tar.bz2
gentoo-c9269d95522eedd2c9d8ea7d9fca808c3a4cf0f5.zip
app-emacs/counsel: new package; add version 0.13.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/counsel/Manifest1
-rw-r--r--app-emacs/counsel/counsel-0.13.4.ebuild36
-rw-r--r--app-emacs/counsel/files/50counsel-gentoo.el3
-rw-r--r--app-emacs/counsel/metadata.xml15
4 files changed, 55 insertions, 0 deletions
diff --git a/app-emacs/counsel/Manifest b/app-emacs/counsel/Manifest
new file mode 100644
index 000000000000..01a00abc7179
--- /dev/null
+++ b/app-emacs/counsel/Manifest
@@ -0,0 +1 @@
+DIST swiper-0.13.4.tar.gz 245190 BLAKE2B c4da021b92fcedfec39cc60f670c97e4a421b8d4aef8183f50c4872bed835db79884cff113f58cf21dfa7ce33158218aa0cf25d72fc0081dc1c24a3b4376c60e SHA512 bf096a13f675f87af6ea68c974455896b64921ca4d7880c9ccc444aa3cea7c7e04c61be5deb2fd57d0568ff4d86f96ffcf94494b55d84d7a9f647f49b69aec9a
diff --git a/app-emacs/counsel/counsel-0.13.4.ebuild b/app-emacs/counsel/counsel-0.13.4.ebuild
new file mode 100644
index 000000000000..fe5b3a0a93e8
--- /dev/null
+++ b/app-emacs/counsel/counsel-0.13.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.5
+
+inherit elisp
+
+DESCRIPTION="Versions of common Emacs commands customized to make the best use of ivy"
+HOMEPAGE="https://github.com/abo-abo/swiper/"
+SRC_URI="https://github.com/abo-abo/swiper/archive/${PV}.tar.gz
+ -> swiper-${PV}.tar.gz"
+S="${WORKDIR}"/swiper-${PV}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # Ivy, Swiper and Counsel tests are performed in app-emacs/ivy
+
+RDEPEND="
+ >=app-emacs/ivy-${PV}
+ >=app-emacs/swiper-${PV}
+"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile ${PN}.el
+}
+
+src_install() {
+ elisp-install ${PN} ${PN}.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}
diff --git a/app-emacs/counsel/files/50counsel-gentoo.el b/app-emacs/counsel/files/50counsel-gentoo.el
new file mode 100644
index 000000000000..1da49244a09f
--- /dev/null
+++ b/app-emacs/counsel/files/50counsel-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'counsel-mode "counsel"
+ "Toggle Counsel mode on or off." t)
diff --git a/app-emacs/counsel/metadata.xml b/app-emacs/counsel/metadata.xml
new file mode 100644
index 000000000000..37581bba4db7
--- /dev/null
+++ b/app-emacs/counsel/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <changelog>https://raw.githubusercontent.com/abo-abo/swiper/master/doc/Changelog.org</changelog>
+ <bugs-to>https://github.com/abo-abo/swiper/issues/</bugs-to>
+ <remote-id type="github">abo-abo/swiper</remote-id>
+ <doc lang="en">https://oremacs.com/swiper/</doc>
+ </upstream>
+</pkgmetadata>