summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-01-21 01:47:52 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-21 02:41:00 +0100
commitc9273a1274587c2922c001505b14a76647640266 (patch)
treec6b52a4ee896824350f22376ee3079ca01949a8c
parentdev-python/pytools: bump to 2016.2.6, EAPI=6, fix deps (diff)
downloadgentoo-c9273a1274587c2922c001505b14a76647640266.tar.gz
gentoo-c9273a1274587c2922c001505b14a76647640266.tar.bz2
gentoo-c9273a1274587c2922c001505b14a76647640266.zip
dev-python/pytools: live ebuild: add py3.5, update git repo URI
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3572
-rw-r--r--dev-python/pytools/pytools-9999.ebuild26
1 files changed, 17 insertions, 9 deletions
diff --git a/dev-python/pytools/pytools-9999.ebuild b/dev-python/pytools/pytools-9999.ebuild
index 7bd405b270a9..f11d02d88c1a 100644
--- a/dev-python/pytools/pytools-9999.ebuild
+++ b/dev-python/pytools/pytools-9999.ebuild
@@ -1,28 +1,36 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4} )
-EGIT_MIN_CLONE_TYPE=single
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
inherit distutils-r1 git-r3
DESCRIPTION="A collection of tools missing from the Python standard library"
-HOMEPAGE="http://mathema.tician.de/software/pytools"
-EGIT_REPO_URI="http://git.tiker.net/trees/pytools.git"
+HOMEPAGE="https://mathema.tician.de/software/pytools/"
+EGIT_REPO_URI="https://github.com/inducer/pytools"
LICENSE="MIT"
SLOT="0"
KEYWORDS=""
IUSE="test"
+RDEPEND="
+ >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.8.0[${PYTHON_USEDEP}]
+"
DEPEND="
>=dev-python/setuptools-0.7.2[${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-RDEPEND=""
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
python_test() {
py.test -v || die "Tests fail with ${EPYTHON}"