summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-04-09 17:07:39 +0200
committerMichał Górny <mgorny@gentoo.org>2019-04-09 18:09:02 +0200
commitc9379cfd4385b5038edcdc64d8ca6ca9c1d021e5 (patch)
tree8ea0232ee679bc2135717de746bbfe254df9e64b
parentxfce-extra/xfce4-time-out-plugin: Port to EAPI 7, off xfconf (diff)
downloadgentoo-c9379cfd.tar.gz
gentoo-c9379cfd.tar.bz2
gentoo-c9379cfd.zip
xfce-extra/xfce4-vala: Bump to EAPI 7, port off xfconf
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-extra/xfce4-vala/xfce4-vala-4.10.3-r4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-vala/xfce4-vala-4.10.3-r4.ebuild b/xfce-extra/xfce4-vala/xfce4-vala-4.10.3-r4.ebuild
new file mode 100644
index 000000000000..e2874c8d21ec
--- /dev/null
+++ b/xfce-extra/xfce4-vala/xfce4-vala-4.10.3-r4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION=0.32
+VALA_MAX_API_VERSION=${VALA_MIN_API_VERSION}
+VALA_USE_DEPEND=vapigen
+inherit vala
+
+DESCRIPTION="Vala bindings for the Xfce desktop environment"
+HOMEPAGE="https://wiki.xfce.org/vala-bindings"
+SRC_URI="https://archive.xfce.org/src/bindings/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="$(vala_depend)
+ >=xfce-base/exo-0.10:=
+ >=xfce-base/garcon-0.2:=
+ >=xfce-base/libxfce4ui-4.10:=
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/xfce4-panel-4.10:=
+ >=xfce-base/xfconf-4.10:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+}
+
+src_configure() {
+ local myconf=(
+ "--with-vala-api=${VALA_MIN_API_VERSION}"
+ )
+
+ vala_src_prepare
+ econf "${myconf[@]}"
+}