summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-30 05:19:37 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-30 06:48:13 -0400
commitc93bd722e0b57cf2313f3eb97e50e4277cfce344 (patch)
treefebf39b711567fc06942b19588b697e4340f7ec9
parentx11-misc/xkeycaps: force gcc -E for imake's generation (diff)
downloadgentoo-c93bd722.tar.gz
gentoo-c93bd722.tar.bz2
gentoo-c93bd722.zip
x11-misc/xsnap: force gcc -E for imake's generation
Requires traditional cpp support and is broken in all sort of ways with clang-cpp / -E. Can still use clang & friends for everything else. Ideally these packages need to be built another way or last rited, imake will just accumulate more problems. Bug: https://bugs.gentoo.org/870811 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--x11-misc/xsnap/xsnap-1.5.15-r2.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/x11-misc/xsnap/xsnap-1.5.15-r2.ebuild b/x11-misc/xsnap/xsnap-1.5.15-r2.ebuild
index dd43dcab6432..bc17eb259842 100644
--- a/x11-misc/xsnap/xsnap-1.5.15-r2.ebuild
+++ b/x11-misc/xsnap/xsnap-1.5.15-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -24,11 +24,14 @@ RDEPEND="
${COMMON_DEPEND}
media-fonts/font-misc-misc
"
-DEPEND="${COMMON_DEPEND}"
+DEPEND="
+ ${COMMON_DEPEND}
+ x11-base/xorg-proto
+"
BDEPEND="
app-text/rman
dev-lang/perl
- x11-base/xorg-proto
+ sys-devel/gcc
>=x11-misc/imake-1.0.8-r1
"
DOCS=( AUTHORS Changelog README )
@@ -50,7 +53,7 @@ src_prepare() {
src_configure() {
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
- IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf || die
+ IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf || die
}
src_compile() {