summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-21 14:00:41 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-21 14:30:12 +0200
commitc93c777211efe4da54e15f212a19657452510d06 (patch)
tree4e00da50cbd59f117bcbdef038ff8229b172ec15
parentx11-plugins/pidgin-gpg: bump to EAPI 8 (diff)
downloadgentoo-c93c777211efe4da54e15f212a19657452510d06.tar.gz
gentoo-c93c777211efe4da54e15f212a19657452510d06.tar.bz2
gentoo-c93c777211efe4da54e15f212a19657452510d06.zip
dev-python/paho-mqtt: Bump to 1.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/paho-mqtt/Manifest1
-rw-r--r--dev-python/paho-mqtt/paho-mqtt-1.6.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/paho-mqtt/Manifest b/dev-python/paho-mqtt/Manifest
index 6c31a90cfb4b..835b27430bec 100644
--- a/dev-python/paho-mqtt/Manifest
+++ b/dev-python/paho-mqtt/Manifest
@@ -1 +1,2 @@
DIST paho-mqtt-1.5.1.tar.gz 144740 BLAKE2B 1c218f1109476fe9b28c26e1113717448377c53a2b9e01437f93d4a29f77e3b61f59492c263f160825ddcce25f907dbf72d3078954cc378d4846afb435d79bba SHA512 7e686bcc702f70c45ab061aa9833d42c4356d5002d27a035a685ca384a5b7d5e9dfd88ac95183816e08dd131463582707acd1d2e0f6de0f7dbbb6a6d0a615c97
+DIST paho-mqtt-1.6.0.tar.gz 145605 BLAKE2B 8f8dfba1c57520793041221e470258a644a0e5c9d462244615f7d7481d1ef8ef4d3209ea9664c4f34bcd70f07addd7fbfbe5857853339b02a266ad2e43acbf90 SHA512 06a18a83b6743c816b4323324c78906ea8937366424d2c3aab3eac565dff040254f1384500cee9cff60d3931131b9f6298ae24795eaff486b03fc998140ece72
diff --git a/dev-python/paho-mqtt/paho-mqtt-1.6.0.ebuild b/dev-python/paho-mqtt/paho-mqtt-1.6.0.ebuild
new file mode 100644
index 000000000000..d920cf440c4c
--- /dev/null
+++ b/dev-python/paho-mqtt/paho-mqtt-1.6.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client class with support for MQTT v5.0, v3.1.1, and v3.1"
+HOMEPAGE="https://www.eclipse.org/paho/index.php?page=clients/python https://github.com/eclipse/paho.mqtt.python"
+SRC_URI="https://github.com/eclipse/paho.mqtt.python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/paho.mqtt.python-${PV}"
+
+LICENSE="EPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ ) "
+
+distutils_enable_tests pytest