summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-08-15 22:04:35 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-07 14:12:15 +0200
commitc94dffbcdb11259e49c102b884621144a685bd67 (patch)
treeb21221b98398da10439d27750a312e9d4c01ad68
parentmedia-sound/wavsplit: EAPI7 revbump, improve ebuild (diff)
downloadgentoo-c94dffbc.tar.gz
gentoo-c94dffbc.tar.bz2
gentoo-c94dffbc.zip
media-sound/id3v2: add EAPI7 ebuild
Closes: https://bugs.gentoo.org/663720 Closes: https://github.com/gentoo/gentoo/pull/9583
-rw-r--r--media-sound/id3v2/id3v2-0.1.12-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-sound/id3v2/id3v2-0.1.12-r1.ebuild b/media-sound/id3v2/id3v2-0.1.12-r1.ebuild
new file mode 100644
index 000000000000..425d6e7587fa
--- /dev/null
+++ b/media-sound/id3v2/id3v2-0.1.12-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A command line editor for id3v2 tags"
+HOMEPAGE="http://id3v2.sourceforge.net/"
+SRC_URI="mirror://sourceforge/id3v2/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+
+DEPEND="media-libs/id3lib"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ emake clean
+}
+
+src_configure() {
+ tc-export CC CXX
+}
+
+src_install() {
+ dobin id3v2
+ doman id3v2.1
+ einstalldocs
+}