summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2019-06-05 10:35:48 +0200
committerFabian Groffen <grobian@gentoo.org>2019-06-05 10:36:51 +0200
commitc9514e9f01b8888b09da6062a42256fe2e156208 (patch)
treeb72f56e7790610638383f1de6f3624d4cafca755
parentapp-crypt/libb2: unset USE=native-clags by default (diff)
downloadgentoo-c9514e9f.tar.gz
gentoo-c9514e9f.tar.bz2
gentoo-c9514e9f.zip
app-crypt/libb2: move away from ltprune.eclass
Signed-off-by: Fabian Groffen <grobian@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
-rw-r--r--app-crypt/libb2/libb2-0.98.1.ebuild4
-rw-r--r--app-crypt/libb2/libb2-0.98.ebuild6
2 files changed, 5 insertions, 5 deletions
diff --git a/app-crypt/libb2/libb2-0.98.1.ebuild b/app-crypt/libb2/libb2-0.98.1.ebuild
index 3212a3234b03..33493fbb9ef1 100644
--- a/app-crypt/libb2/libb2-0.98.1.ebuild
+++ b/app-crypt/libb2/libb2-0.98.1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit autotools ltprune toolchain-funcs
+inherit autotools toolchain-funcs
DESCRIPTION="C library providing BLAKE2b, BLAKE2s, BLAKE2bp, BLAKE2sp"
HOMEPAGE="https://github.com/BLAKE2/libb2"
@@ -53,5 +53,5 @@ src_compile() {
src_install() {
default
- prune_libtool_files
+ use static || find "${ED}" -name '*.la' -type f -delete || die
}
diff --git a/app-crypt/libb2/libb2-0.98.ebuild b/app-crypt/libb2/libb2-0.98.ebuild
index 3ca37501441b..64ec18c1de9e 100644
--- a/app-crypt/libb2/libb2-0.98.ebuild
+++ b/app-crypt/libb2/libb2-0.98.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools ltprune
+inherit autotools
DESCRIPTION="C library providing BLAKE2b, BLAKE2s, BLAKE2bp, BLAKE2sp"
HOMEPAGE="https://github.com/BLAKE2/libb2"
@@ -40,5 +40,5 @@ src_compile() {
src_install() {
default
- prune_libtool_files
+ use static || find "${ED}" -name '*.la' -type f -delete || die
}