summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Seren <guillaumeseren@gmail.com>2019-10-17 11:56:57 +0200
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-10-25 13:38:58 -0700
commitc983495ad3116f3c02c2ec0abbd3a6e1697e61de (patch)
tree6695407fc94736c0e67a623e09c4488b53552693
parentapp-shells/loksh: bump to 6.6 (diff)
downloadgentoo-c983495a.tar.gz
gentoo-c983495a.tar.bz2
gentoo-c983495a.zip
app-emulation/vagrant: Add version bump 2.2.6
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Guillaume Seren <guillaumeseren@gmail.com> Closes: https://bugs.gentoo.org/697920 Closes: https://github.com/gentoo/gentoo/pull/13323 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--app-emulation/vagrant/Manifest1
-rw-r--r--app-emulation/vagrant/vagrant-2.2.6.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-emulation/vagrant/Manifest b/app-emulation/vagrant/Manifest
index 2f96176657be..307430a6bf15 100644
--- a/app-emulation/vagrant/Manifest
+++ b/app-emulation/vagrant/Manifest
@@ -2,3 +2,4 @@ DIST vagrant-2.1.5.tar.gz 1238788 BLAKE2B 8e3dfeb4d830fde1984c08b16422c99b51ce45
DIST vagrant-2.2.2.tar.gz 1223645 BLAKE2B 595d26a11f27a23a9e66386820dec7c23fbafe079e9e9750e7cbc928cac2e965782abbb062f6b04efd367b56297d040af2b4f4f56d6df06e604f018110e10329 SHA512 70c83fcd896ae3b84fac22c539eb85db9bf08c8f75108d5f2b86841821cf7a885b72565814519b6f2ef3422d84d2f67fc402b983b1a15c1edfd0dc78196cd957
DIST vagrant-2.2.4.tar.gz 1244111 BLAKE2B ac6b92c1f2b1cc3428b3be8985b07a087f6a075a2b60c93abc74dbff1f5679f648c0bbfc1af772fc10e90899b856a9f318d5d2e4f5a4c9e04452ed95ea356088 SHA512 9d1e9dd42a009d4df159ae3887f43a2664714077a91013a8b63dad72d25d4a236e1dba6daf66443101904f89a5cd37baff65be2714124f7b9f822f26669bcc5a
DIST vagrant-2.2.5.tar.gz 1272879 BLAKE2B f89aed3e07f12b3390f1db089cc15bc091ee19336174260d39534c32b69a5f4682cc4d84295f81aeec80781e942b66266b37b3032aba562471ecb596d9309e92 SHA512 dc95e566588987b9199e66ee5f548be573bd62e229d2e4de5447f43f25a1a7129377935ec6dc73cc1f53acc29c08b0a4fabebf1a58310f175cc6d37b856c9272
+DIST vagrant-2.2.6.tar.gz 1285530 BLAKE2B 802537b56429366ab0dab08d5490f2a5c1ec3810e9c04573ccd11f27078fc375f092ed70b27a7846813cbde5fdce0aa90399eba07e19a9d6ae7e11cb47204efe SHA512 6d8b5b1d4e5cc482404cf4c59e1b7cf9502a9819569b5098e44874733cee706f26adb4ac7994abe7e3307ca69d3003e2604dc859ce460c53d766d78b8d9fe22a
diff --git a/app-emulation/vagrant/vagrant-2.2.6.ebuild b/app-emulation/vagrant/vagrant-2.2.6.ebuild
new file mode 100644
index 000000000000..d3796ed1651a
--- /dev/null
+++ b/app-emulation/vagrant/vagrant-2.2.6.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
+RUBY_FAKEGEM_EXTRAINSTALL="keys plugins templates version.txt"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit bash-completion-r1 ruby-fakegem
+
+DESCRIPTION="A tool for building and distributing development environments"
+HOMEPAGE="https://vagrantup.com/"
+SRC_URI="https://github.com/hashicorp/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+virtualbox"
+RESTRICT="test"
+
+RDEPEND="${RDEPEND}
+ app-arch/libarchive
+ net-misc/curl
+ virtualbox? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"
+
+ruby_add_rdepend "
+ >=dev-ruby/bcrypt_pbkdf-1.0.0
+ >=dev-ruby/childprocess-0.6.0
+ >=dev-ruby/ed25519-1.2.4
+ >=dev-ruby/erubis-2.7.0
+ >=dev-ruby/hashicorp-checkpoint-0.1.5
+ >=dev-ruby/i18n-1.1.1:1
+ >=dev-ruby/listen-3.1.5
+ <dev-ruby/log4r-1.1.11
+ <dev-ruby/mime-types-3:*
+ >=dev-ruby/net-ssh-5.1.0:*
+ >=dev-ruby/net-sftp-2.1
+ >=dev-ruby/net-scp-1.2.0
+ dev-ruby/rest-client:2
+ >=dev-ruby/rubyzip-1.2.2:*
+ >=dev-ruby/vagrant_cloud-2.0.3
+"
+
+# upstream specifies rake>=12 but it apparently doesn't need something this
+# recent. Because vagrant builds fine with rake 10 and because stabilizing rake
+# is tricky, we specify a lower dependency requirement here. This way, we'll be
+# able to stabilize vagrant sooner.
+ruby_add_bdepend "
+ >=dev-ruby/rake-10.5.0
+"
+
+all_ruby_prepare() {
+ # remove bundler support
+ sed -i '/[Bb]undler/d' Rakefile || die
+ rm Gemfile || die
+
+ # loosen dependencies
+ sed -e '/hashicorp-checkpoint\|i18n\|listen\|net-ssh\|net-scp\|rake\|childprocess/s/~>/>=/' \
+ -e '/ruby_dep/s/<=/>=/' \
+ -i ${PN}.gemspec || die
+
+ # remove windows-specific gems
+ sed -e '/wdm\|winrm/d' \
+ -i ${PN}.gemspec || die
+
+ # remove bsd-specific gems
+ sed -e '/rb-kqueue/d' \
+ -i ${PN}.gemspec || die
+
+ sed -e "s/@VAGRANT_VERSION@/${PV}/g" "${FILESDIR}/${PN}-r1.in" > "${PN}" || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ newbashcomp contrib/bash/completion.sh ${PN}
+
+ # provide executable similar to upstream:
+ # https://github.com/hashicorp/vagrant-installers/blob/master/substrate/modules/vagrant_installer/templates/vagrant.erb
+ dobin "${PN}"
+
+ # directory for plugins.json
+ keepdir /var/lib/vagrant
+
+ insinto /usr/share/vim/vimfiles/syntax/
+ doins contrib/vim/vagrantfile.vim
+}