summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-01-08 15:00:50 +0100
committerHans de Graaff <graaff@gentoo.org>2019-01-09 09:07:10 +0100
commitc9a5fdaf47540b075a0fbc456aa779b4cdd7d40d (patch)
treef7e3891e3cb54c3d669078c86a27e6db3fafc63c
parentdev-ruby/ffi: add 1.10.0 (diff)
downloadgentoo-c9a5fdaf47540b075a0fbc456aa779b4cdd7d40d.tar.gz
gentoo-c9a5fdaf47540b075a0fbc456aa779b4cdd7d40d.tar.bz2
gentoo-c9a5fdaf47540b075a0fbc456aa779b4cdd7d40d.zip
dev-ruby/thor: add ruby26
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--dev-ruby/thor/thor-0.20.3.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-ruby/thor/thor-0.20.3.ebuild b/dev-ruby/thor/thor-0.20.3.ebuild
index d80e48320449..1b44a1408aae 100644
--- a/dev-ruby/thor/thor-0.20.3.ebuild
+++ b/dev-ruby/thor/thor-0.20.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25"
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
@@ -22,7 +22,7 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux"
IUSE="doc"
-USE_RUBY="ruby23 ruby24" ruby_add_bdepend "
+USE_RUBY="ruby23 ruby24 ruby25" ruby_add_bdepend "
test? (
dev-ruby/childlabor
dev-ruby/webmock
@@ -48,7 +48,7 @@ all_ruby_prepare() {
each_ruby_test() {
case ${RUBY} in
- *ruby25)
+ *ruby26)
einfo "Skipping tests due to circular dependencies"
;;
*)