summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-16 07:25:10 +0100
committerSam James <sam@gentoo.org>2023-05-16 07:27:48 +0100
commitc9a9956944acab031669f00023398c45cef187e9 (patch)
treedae5b373d4606bf9a8187d33f011c29f2b34607a
parentnet-misc/asterisk: Stabilize 18.17.0 x86, #896156 (diff)
downloadgentoo-c9a9956944acab031669f00023398c45cef187e9.tar.gz
gentoo-c9a9956944acab031669f00023398c45cef187e9.tar.bz2
gentoo-c9a9956944acab031669f00023398c45cef187e9.zip
sys-devel/gdb: fix build w/ musl-1.2.4
Closes: https://bugs.gentoo.org/905922 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-devel/gdb/files/gdb-13.1-musl-lfs.patch23
-rw-r--r--sys-devel/gdb/gdb-13.1.90_p20230429.ebuild1
2 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/gdb/files/gdb-13.1-musl-lfs.patch b/sys-devel/gdb/files/gdb-13.1-musl-lfs.patch
new file mode 100644
index 000000000000..d7778e305903
--- /dev/null
+++ b/sys-devel/gdb/files/gdb-13.1-musl-lfs.patch
@@ -0,0 +1,23 @@
+https://bugs.gentoo.org/905922
+https://sourceware.org/bugzilla/show_bug.cgi?id=30450
+https://sourceware.org/git/?p=binutils-gdb.git;a=commit;h=2e977d9901393ea1bacbe1896af0929e968bc811
+
+From 2e977d9901393ea1bacbe1896af0929e968bc811 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 22 Feb 2023 16:28:22 -0800
+Subject: [PATCH] gdbserver/linux-low.cc: Fix a typo in ternary operator
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/gdbserver/linux-low.cc
++++ b/gdbserver/linux-low.cc
+@@ -5390,7 +5390,7 @@ proc_xfer_memory (CORE_ADDR memaddr, unsigned char *readbuf,
+ if (lseek (fd, memaddr, SEEK_SET) != -1)
+ bytes = (readbuf != nullptr
+ ? read (fd, readbuf, len)
+- ? write (fd, writebuf, len));
++ : write (fd, writebuf, len));
+ #endif
+
+ if (bytes < 0)
+--
+2.31.1
diff --git a/sys-devel/gdb/gdb-13.1.90_p20230429.ebuild b/sys-devel/gdb/gdb-13.1.90_p20230429.ebuild
index d75794a2864b..e6030f478386 100644
--- a/sys-devel/gdb/gdb-13.1.90_p20230429.ebuild
+++ b/sys-devel/gdb/gdb-13.1.90_p20230429.ebuild
@@ -111,6 +111,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-8.3.1-verbose-build.patch
"${FILESDIR}"/${PN}-13.1-Wenum-constexpr-conversion-clang16.patch
+ "${FILESDIR}"/${PN}-13.1-musl-lfs.patch
)
pkg_setup() {