summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-10-10 04:52:33 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-10-10 10:49:22 -0400
commitc9c10083160b19f55183093890cbe1ced8061763 (patch)
tree20caa1ce2436677212167804e356ae07e3c7bbb3
parentdev-qt/qtimageformats: add 6.6.0 (diff)
downloadgentoo-c9c10083160b19f55183093890cbe1ced8061763.tar.gz
gentoo-c9c10083160b19f55183093890cbe1ced8061763.tar.bz2
gentoo-c9c10083160b19f55183093890cbe1ced8061763.zip
dev-qt/qtlocation: add 6.6.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-qt/qtlocation/Manifest1
-rw-r--r--dev-qt/qtlocation/qtlocation-6.6.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
index 457935a7b111..f1b415bd8982 100644
--- a/dev-qt/qtlocation/Manifest
+++ b/dev-qt/qtlocation/Manifest
@@ -4,6 +4,7 @@ DIST qtlocation-everywhere-opensource-src-5.15.10.tar.xz 6552240 BLAKE2B 1e44bda
DIST qtlocation-everywhere-opensource-src-5.15.11.tar.xz 6554216 BLAKE2B e882ecdc4f565f48874371e5235dc96769fbded9446a2a7f1afd869217f4bc75a9f42c6c34627311b55fbfc60da9a95fc7472c3ced83fca722799497b437a9d9 SHA512 d439d03ff9044fc70165d1ceb5def9ec3290beec56b3e893409a24cd355651a4317e0eadff0266d38203ff84429a5fb8659a200f094669716579b6791a1a0f6d
DIST qtlocation-everywhere-src-6.5.2.tar.xz 3032488 BLAKE2B c8cd34980b0f78326fb70bf76a04094cf3e27afbd6aed6d982ce30abfa9dc4250d164dbe11c1027bedcdeee3b7c907c3716e88f16eeae173b846ccdf2c38d458 SHA512 b1e5c1813deb8a4eb9f8548afa935f1a2145ed3168f0276493ea501057fd4f70b8980ae387248a59e50f0e450ae245a04cd8636fb61d37af9c3634ff1cdd24f3
DIST qtlocation-everywhere-src-6.5.3.tar.xz 3032844 BLAKE2B 3b23b8d1b1a06476428879c0d32d3fc21119e50410d97ee3948c0ab7b22832f27f1e5ed2d06e62f53baf668b77630a27e5c6814b54c2e9498706a436256c4005 SHA512 6633dedba335b8de4c96f98f4709a147e225e82fee1ed741938e15e1540421ad7c3140baec75914f0844a793433abcadaf3ce72d944662b62778327d65ff7348
+DIST qtlocation-everywhere-src-6.6.0.tar.xz 3035992 BLAKE2B 9adfb9bfc91cecaac473b517b223d590bf762393c387346e55f5f1ee4a3e59b2377c0ed4de037c45ebe5fb1e2997980c400fa587fbd1f503aa6531b6438840a1 SHA512 e4e492229d961bc34630aaff030b46385708312de174c9c47f85a6010f1fcb74e198333920fd5c02153a8bbae770c83d8cd1777177d9c9d7a1d555b6619be8f2
DIST qtlocation-mapboxgl-5.15.10-4c88f2c0.tar.gz 3726387 BLAKE2B e9b818505ace86516262d1407450c14be82122bb91363a57708795844089371ac7d511a857f713c7cb4e6f8b54867aab0bc5dcdb9c49aa28aa3f8363271378e0 SHA512 e4d9133db892fd8b7b1bcf584bf7dae30c0f0353f3b0a696a6cabc9485067f262d42554b583640521734498572e5480b5e8d0143d5be47bb92077f3192fefa4d
DIST qtlocation-mapboxgl-5.15.10-5a07e196.tar.gz 3726230 BLAKE2B 9dbe08088a55bc1da4952a628af987b3b056615e883983d3a5e2eb392ce4aff16bfd753f84bbad07f9a415fbd275ec9933a64b6bcfd27ea6d8adced6d2adcac7 SHA512 ec3de81f643388690eda45d073a9c6f908d8efeff30cd062d9afcd1f94c6b45b301327747928d45b4047ce04b7df5b0afaf9e8942e22660711a5ac49787829eb
DIST qtlocation-mapboxgl-5.15.11-4c88f2c0.tar.gz 3726387 BLAKE2B e9b818505ace86516262d1407450c14be82122bb91363a57708795844089371ac7d511a857f713c7cb4e6f8b54867aab0bc5dcdb9c49aa28aa3f8363271378e0 SHA512 e4d9133db892fd8b7b1bcf584bf7dae30c0f0353f3b0a696a6cabc9485067f262d42554b583640521734498572e5480b5e8d0143d5be47bb92077f3192fefa4d
diff --git a/dev-qt/qtlocation/qtlocation-6.6.0.ebuild b/dev-qt/qtlocation/qtlocation-6.6.0.ebuild
new file mode 100644
index 000000000000..05a2dc329b2f
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-6.6.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Location (places, maps, navigation) library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[network]
+ ~dev-qt/qtdeclarative-${PV}:6
+ ~dev-qt/qtpositioning-${PV}:6[qml]
+"
+DEPEND="${RDEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # ignores QML_IMPORT_PATH (unlike other tests) and looks in
+ # the missing builddir/qml, skip rather than work around
+ tst_declarative_ui
+)
+
+src_install() {
+ qt6-build_src_install
+
+ if use test; then
+ local delete=( # sigh
+ "${D}${QT6_LIBDIR}"/cmake/Qt6Location/*TestGeoServicePlugin*.cmake
+ "${D}${QT6_LIBDIR}"/cmake/Qt6Location/*UnsupportedPlacesGeoServicePlugin*.cmake
+ "${D}${QT6_LIBDIR}"/cmake/Qt6Qml/QmlPlugins/*declarative_location_test*.cmake
+ "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_geocodingplugin.so
+ "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_placesplugin_unsupported.so
+ "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_qmltestplugin.so
+ "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_routingplugin.so
+ "${D}${QT6_QMLDIR}"/QtLocation/Test
+ )
+ # using -f given not tracking which tests may be skipped or not
+ rm -rf -- "${delete[@]}" || die
+ fi
+}