summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-29 07:52:22 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-29 08:23:12 +0200
commitc9d84cfcb289cc5244df20d9f3ab1142bb4d8758 (patch)
tree932f15f7f99ee97afc61c7ad0f008a533aee8d25
parentdev-python/greenstalk: Bump to 2.0.2 (diff)
downloadgentoo-c9d84cfcb289cc5244df20d9f3ab1142bb4d8758.tar.gz
gentoo-c9d84cfcb289cc5244df20d9f3ab1142bb4d8758.tar.bz2
gentoo-c9d84cfcb289cc5244df20d9f3ab1142bb4d8758.zip
dev-python/slixmpp: Bump to 1.8.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/slixmpp/Manifest1
-rw-r--r--dev-python/slixmpp/slixmpp-1.8.4.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/slixmpp/Manifest b/dev-python/slixmpp/Manifest
index eed5a97014bc..4ed6b2d81e23 100644
--- a/dev-python/slixmpp/Manifest
+++ b/dev-python/slixmpp/Manifest
@@ -1 +1,2 @@
DIST slixmpp-1.8.3.tar.gz 1053891 BLAKE2B cecf307406f093e8b069a70485edf38a95054b2d299b0a34064e582c20243d8f90ea557079cde9b22bb1b3b9e3e7d452347625bb2c21def461193360290b4d62 SHA512 2d499c106bcb8d86a8522e617d855f5c6aeb5e3e7f3757331baef1bcfa4e81d24ef6a554e760e323ab1b542c168dae4cb99ea56db92f5539542045ac6c8b9c9d
+DIST slixmpp-1.8.4.tar.gz 546263 BLAKE2B 78a7b1b9015f27d63b3c127a292e2794a9de2283fbb9763ef52d03d37cc2d0fcc3f0696beca858a0d120991059a5eced62b5a4a9e87436b81dc17f6bbdc4b106 SHA512 afa82670e4cb2c904503a6ef652d3f2ecd59732a18eef05b85e0a55f15112685ecc1b50951b3f717a211d1c9069a4e7c65d913454426441f56688ff05a5c0921
diff --git a/dev-python/slixmpp/slixmpp-1.8.4.ebuild b/dev-python/slixmpp/slixmpp-1.8.4.ebuild
new file mode 100644
index 000000000000..0e6c3ea4c37c
--- /dev/null
+++ b/dev-python/slixmpp/slixmpp-1.8.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 3 library for XMPP"
+HOMEPAGE="https://lab.louiz.org/poezio/slixmpp"
+LICENSE="MIT"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://lab.louiz.org/poezio/${PN}.git"
+ inherit git-r3
+else
+ inherit pypi
+ KEYWORDS="~amd64 ~riscv"
+fi
+
+DEPEND="
+ net-dns/libidn:=
+"
+RDEPEND="
+ dev-python/aiodns[${PYTHON_USEDEP}]
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ ${DEPEND}
+"
+
+distutils_enable_tests unittest