summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-07-04 00:07:05 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-07-04 00:42:14 +0200
commitc9fe49c0e1d1e70dea340e0efe9d8417e0f49df8 (patch)
tree7be311ada9e1c599b069b290adafecf975b9ebdc
parentdev-lang/fuzion: drop old 0.081 (diff)
downloadgentoo-c9fe49c0e1d1e70dea340e0efe9d8417e0f49df8.tar.gz
gentoo-c9fe49c0e1d1e70dea340e0efe9d8417e0f49df8.tar.bz2
gentoo-c9fe49c0e1d1e70dea340e0efe9d8417e0f49df8.zip
dev-lang/fuzion: bump to 0.083
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-lang/fuzion/Manifest1
-rw-r--r--dev-lang/fuzion/fuzion-0.083.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-lang/fuzion/Manifest b/dev-lang/fuzion/Manifest
index cc4ad309c8de..ceab4890dda9 100644
--- a/dev-lang/fuzion/Manifest
+++ b/dev-lang/fuzion/Manifest
@@ -1 +1,2 @@
DIST fuzion-0.082.tar.gz 751728 BLAKE2B d876d8bc762e9f2bee25e93aee0b118721136398f9e6c98e70adc50ce684fdcaa15991448ca748b1ae1f348e5facc442277b600ab3b5a809284144aa2f9b4928 SHA512 17cd56186e0fd7e07d5f592b7f8edc47e2609d0a6df08877c1db773f9ac56d8fd8ce60a1b7cffd918e23e20fad29a4c05c49d95a07cc3bec492e67d749837c83
+DIST fuzion-0.083.tar.gz 830470 BLAKE2B dcd320fbc8e4e426857f26004678e6e768d3baa987668db2c8b6e2b52c8dfffecd4e65f5d3930f7aa0726b0ae5be1a6266c6721fd4de7d0d277e2e779adaf3ff SHA512 1f727bb280d3de15f085093eac63810c6cadb6e8a5939d288abdbd5b79f4bb982e568dba484c5db087b3050635330f4b93d81c457ec50c7e2e9ceb21dc89dea5
diff --git a/dev-lang/fuzion/fuzion-0.083.ebuild b/dev-lang/fuzion/fuzion-0.083.ebuild
new file mode 100644
index 000000000000..b37d2fb1f8dc
--- /dev/null
+++ b/dev-lang/fuzion/fuzion-0.083.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit java-pkg-2
+
+DESCRIPTION="A language with a focus on simplicity, safety and correctness"
+HOMEPAGE="https://flang.dev/
+ https://github.com/tokiwa-software/fuzion/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tokiwa-software/${PN}.git"
+else
+ SRC_URI="https://github.com/tokiwa-software/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=virtual/jre-17:*
+ dev-libs/boehm-gc
+"
+DEPEND=">=virtual/jdk-17:*"
+BDEPEND="test? ( sys-devel/clang:* )"
+
+DOCS=( README.md release_notes.md )
+
+src_compile() {
+ emake -j1
+}
+
+src_test() {
+ emake -j1 run_tests_parallel
+}
+
+src_install() {
+ # Remove unnecessary files from build directory. bug #893450
+ local torm
+ local torm_path
+ for torm in tests run_tests.{failures,results} ; do
+ torm_path="${S}"/build/${torm}
+
+ if [[ -e "${torm_path}" ]] ; then
+ rm -r "${torm_path}" || die "failed to remove ${toremove_path}"
+ fi
+ done
+
+ insinto /usr/share/${PN}
+ doins -r build/.
+ insopts -m755
+ doins -r build/bin
+
+ local bin
+ for bin in fz fzjava ; do
+ dosym -r /usr/share/${PN}/bin/${bin} /usr/bin/${bin}
+ done
+
+ einstalldocs
+}