summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-03-12 22:29:32 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-03-12 22:30:01 +0100
commitca0f2c4849c0243fe35ee0df0bb155228b13e907 (patch)
tree3089c70842f528554626b35da0dd62a04c4820ee
parentmail-mta/msmtp: Removed old (diff)
downloadgentoo-ca0f2c4849c0243fe35ee0df0bb155228b13e907.tar.gz
gentoo-ca0f2c4849c0243fe35ee0df0bb155228b13e907.tar.bz2
gentoo-ca0f2c4849c0243fe35ee0df0bb155228b13e907.zip
dev-libs/libxmlb: Bump to version 0.3.0
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--dev-libs/libxmlb/Manifest1
-rw-r--r--dev-libs/libxmlb/libxmlb-0.3.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-libs/libxmlb/Manifest b/dev-libs/libxmlb/Manifest
index d481fbe7efae..c5ffd2c79168 100644
--- a/dev-libs/libxmlb/Manifest
+++ b/dev-libs/libxmlb/Manifest
@@ -1,2 +1,3 @@
DIST libxmlb-0.1.15.tar.gz 92923 BLAKE2B 97b6af812397dd279e7e3c038627fcf8228cbfa5c3af91ceeb5361e32d37d357eda6a193f627a5f4442426fb08abca1ff11684fe199d9d3a4add72ca4f3f5d08 SHA512 58268b3a690af36c0923afdee3ae58e88bf778eebbc6a439be1bc85ed985efdc20cd7006c976586f7be87310dc091d67dddd370f4bbec58379fc4e7349bfa3d8
DIST libxmlb-0.2.1.tar.gz 98284 BLAKE2B b9bf02560a231837d7837b43f01d8f78c54a80319379a7bfa191f8303b77c35e82d1e2bb57722f1bfe56224d96bd1513cef702a0375eb85a137bff8ca3104c5c SHA512 4e082f036eb62626d1724ac5093ad625f9259e9e81aa40d5ca0589a3a72dadd669c0718ff64dcae094973b6c282b6c8f8ce7212b7e47211f320035bb639ec59d
+DIST libxmlb-0.3.0.tar.gz 112097 BLAKE2B a1046ee5c940dfd23a7e3cc07c0deb2be0f18fd416c13df7f467ce98308239191788a1cf18026593862c04645486f4ab332fe71eb96dc5e5abc7909e61451cf0 SHA512 28731c84cab0b1164fc08ea751ee7da22b8f4f278c4950a2d5957cc0dcd4457b6ce47dace25dd7c163a790b7ed2619dd6b4863f8147dc201c18f3433990af2cb
diff --git a/dev-libs/libxmlb/libxmlb-0.3.0.ebuild b/dev-libs/libxmlb/libxmlb-0.3.0.ebuild
new file mode 100644
index 000000000000..a4cc4b2a152c
--- /dev/null
+++ b/dev-libs/libxmlb/libxmlb-0.3.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit meson python-any-r1
+
+DESCRIPTION="Library to help create and query binary XML blobs"
+HOMEPAGE="https://github.com/hughsie/libxmlb"
+SRC_URI="https://github.com/hughsie/libxmlb/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2.1+"
+SLOT="0/2" # libxmlb.so version
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="doc introspection stemmer test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/glib:2
+ sys-apps/util-linux
+ stemmer? ( dev-libs/snowball-stemmer )
+"
+
+DEPEND="
+ ${RDEPEND}
+ doc? ( dev-util/gtk-doc )
+ introspection? ( dev-libs/gobject-introspection )
+"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-util/meson-0.47.0
+ virtual/pkgconfig
+ introspection? (
+ $(python_gen_any_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
+ )
+"
+
+python_check_deps() {
+ has_version -b "dev-python/setuptools[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dgtkdoc="$(usex doc true false)"
+ -Dintrospection="$(usex introspection true false)"
+ -Dstemmer="$(usex stemmer true false)"
+ -Dtests="$(usex test true false)"
+ )
+ meson_src_configure
+}