summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-11-15 11:00:35 +0100
committerPacho Ramos <pacho@gentoo.org>2015-11-15 11:30:08 +0100
commitca1556310d6f2e14ebaafa7397af76f62f86b56f (patch)
treecb52ea81bffd517dddf0acb59ff1a405a613cb79
parentgnome-extra/gnome-weather: Version bump (diff)
downloadgentoo-ca1556310d6f2e14ebaafa7397af76f62f86b56f.tar.gz
gentoo-ca1556310d6f2e14ebaafa7397af76f62f86b56f.tar.bz2
gentoo-ca1556310d6f2e14ebaafa7397af76f62f86b56f.zip
gnome-extra/gnome-weather: Drop old
Package-Manager: portage-2.2.24
-rw-r--r--gnome-extra/gnome-weather/Manifest1
-rw-r--r--gnome-extra/gnome-weather/files/gnome-weather-3.8.2-temp-unit.patch59
-rw-r--r--gnome-extra/gnome-weather/gnome-weather-3.14.1.ebuild34
3 files changed, 0 insertions, 94 deletions
diff --git a/gnome-extra/gnome-weather/Manifest b/gnome-extra/gnome-weather/Manifest
index 8b9ed5f669c4..0685ad7a80eb 100644
--- a/gnome-extra/gnome-weather/Manifest
+++ b/gnome-extra/gnome-weather/Manifest
@@ -1,3 +1,2 @@
-DIST gnome-weather-3.14.1.tar.xz 10520072 SHA256 e3acea9b5e9e7dd5e9d51c2793c568ea7378b08b4de1bcfe7f0b8b3c2004fe87 SHA512 e167fe07aacc0af8aa30ee40f8aca83e735ddc3c7278b221f09fecc82d513f90250e6079425dc04d4ae865a4a265753b9332234795326a84d7b3b1a228f4afa1 WHIRLPOOL 69a9f3ed5a947f3e4f681c9aa8c6a73f772b4496401a61456e33173cf23ebc34fd8a0711aee6bef889c7077c9cb6141e7036de454356ca9932f7b5d13210eca2
DIST gnome-weather-3.16.2.1.tar.xz 10344692 SHA256 0fe481d4be192ca32cb401f3f4b74feb0f1ea3241f23dc51ec1949874836e355 SHA512 a4adb392da018cd4033416ae4d4e481a025455fab69213db9ab7fa42add635e87b9ed846bfa69dfdda591fb0ee58cd63c7486b74659f14e23b1bcd97f4d13e8d WHIRLPOOL 30ce35737658507b6d37cdc6e64a736a81ff0869ec9b48dbca094c1da25f622095411a6f67af731f4d68354b352d69e584c841c89b4abafc7fcafcb1e916cdbb
DIST gnome-weather-3.18.1.tar.xz 5358172 SHA256 d0cbe0ee6e9f9332e30836d72c9a462ecc908a97402943c33cd6e61d08323fdf SHA512 1e04fd932edfb15c16965a17a4865689c7133408b9d05a3e67e3c0dda77b1daf8a027603f66cff85957376626f4ad3d66ac9d28efb0f964667889b894cb66e1c WHIRLPOOL 8efd62cbb789dba43561e59489c9cf951b81bcde8490619a88f4bed850f9365d0c54321820260f1091d0e7f18cc162aafd98834bda096faa6da94d9956fe3be5
diff --git a/gnome-extra/gnome-weather/files/gnome-weather-3.8.2-temp-unit.patch b/gnome-extra/gnome-weather/files/gnome-weather-3.8.2-temp-unit.patch
deleted file mode 100644
index c652651f9737..000000000000
--- a/gnome-extra/gnome-weather/files/gnome-weather-3.8.2-temp-unit.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-From 7c901f42d2837e682f37d85b1fa3ee94922f2a05 Mon Sep 17 00:00:00 2001
-From: Giovanni Campagna <gcampagna@src.gnome.org>
-Date: Mon, 13 May 2013 21:19:49 +0000
-Subject: Add a submenu to the app menu to choose the temperature unit
-
-Among all the preferences in the old dialog, temperature unit
-is the only one that makes real sense, as we don't show wind
-speed, visibility or pressure.
-Also, exclude the Kelvin entry, which is there just to make
-cool screenshots :)
----
-diff --git a/data/app-menu.ui b/data/app-menu.ui
-index 42a16a4..c332595 100644
---- a/data/app-menu.ui
-+++ b/data/app-menu.ui
-@@ -6,12 +6,25 @@
- <attribute name="action">win.new</attribute>
- <attribute name="accel">&lt;Primary&gt;n</attribute>
- </item>
-+ </section>
-+ <submenu>
-+ <attribute translatable="yes" name="label">Temperature unit</attribute>
-+ <item>
-+ <attribute translatable="yes" name="label">Celsius</attribute>
-+ <attribute name="action">app.temperature-unit</attribute>
-+ <attribute name="target">centigrade</attribute>
-+ </item>
-+ <item>
-+ <attribute translatable="yes" name="label">Fahrenheit</attribute>
-+ <attribute name="action">app.temperature-unit</attribute>
-+ <attribute name="target">fahrenheit</attribute>
-+ </item>
-+ </submenu>
-+ <section>
- <item>
- <attribute name="action">win.about</attribute>
- <attribute name="label" translatable="yes">About Weather</attribute>
- </item>
-- </section>
-- <section>
- <item>
- <attribute name="action">app.quit</attribute>
- <attribute name="label" translatable="yes">Quit</attribute>
-diff --git a/src/main.js b/src/main.js
-index 687b79e..844a0d4 100644
---- a/src/main.js
-+++ b/src/main.js
-@@ -76,6 +76,9 @@ const Application = new Lang.Class({
- [{ name: 'quit',
- activate: this._onQuit }]);
-
-+ let gwSettings = new Gio.Settings({ schema: 'org.gnome.GWeather' });
-+ this.add_action(gwSettings.create_action('temperature-unit'));
-+
- this._initAppMenu();
-
- this.add_accelerator("Escape", "win.selection-mode(false)", null);
---
-cgit v0.9.2
diff --git a/gnome-extra/gnome-weather/gnome-weather-3.14.1.ebuild b/gnome-extra/gnome-weather/gnome-weather-3.14.1.ebuild
deleted file mode 100644
index c570659ea889..000000000000
--- a/gnome-extra/gnome-weather/gnome-weather-3.14.1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="no"
-
-inherit eutils gnome2
-
-DESCRIPTION="A weather application for GNOME"
-HOMEPAGE="https://wiki.gnome.org/Design/Apps/Weather"
-
-LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-RDEPEND="
- >=dev-libs/gjs-1.41.4
- >=dev-libs/glib-2.32:2
- >=dev-libs/gobject-introspection-1.35.9
- >=dev-libs/libgweather-3.9.5
- >=x11-libs/gtk+-3.11.4:3
-"
-DEPEND="${RDEPEND}
- dev-util/appdata-tools
- >=dev-util/intltool-0.26
- virtual/pkgconfig
-"
-
-src_configure() {
- # dogtail is not packaged in gentoo
- gnome2_src_configure --disable-dogtail
-}