summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2022-01-23 12:49:01 +0100
committerSam James <sam@gentoo.org>2022-01-28 07:59:05 +0000
commitca28a27a81a6fc1e71a281942a537c1720a48172 (patch)
treeda58c20ddb9e90380d0bc07faf0913e1c8f69a24
parentsys-apps/s6-rc: drop versions (diff)
downloadgentoo-ca28a27a81a6fc1e71a281942a537c1720a48172.tar.gz
gentoo-ca28a27a81a6fc1e71a281942a537c1720a48172.tar.bz2
gentoo-ca28a27a81a6fc1e71a281942a537c1720a48172.zip
sys-apps/s6-rc: respect AR, CC and RANLIB
Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/s6-rc/s6-rc-0.5.2.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-apps/s6-rc/s6-rc-0.5.2.0.ebuild b/sys-apps/s6-rc/s6-rc-0.5.2.0.ebuild
index 6f0a3d47a42a..d260c7317805 100644
--- a/sys-apps/s6-rc/s6-rc-0.5.2.0.ebuild
+++ b/sys-apps/s6-rc/s6-rc-0.5.2.0.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="Service manager for the s6 supervision suite"
HOMEPAGE="https://www.skarnet.org/software/s6-rc/"
SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
@@ -28,9 +30,13 @@ src_prepare() {
# Avoid QA warning for LDFLAGS addition; avoid overriding -fstack-protector
sed -i -e 's/.*-Wl,--hash-style=both$/:/' -e '/-fno-stack-protector$/d' \
configure || die
+
+ sed -i -e '/AR := /d' -e '/RANLIB := /d' Makefile || die
}
src_configure() {
+ tc-export AR CC RANLIB
+
econf \
--bindir=/bin \
--dynlibdir=/usr/$(get_libdir) \