summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-05-14 14:14:36 +0200
committerJason Zaman <perfinion@gentoo.org>2024-05-15 07:37:33 -0700
commitca3e2c711957b6764efdf7fe7c7342ce97a2da65 (patch)
tree1151f888c55e25d73050741e6d3bda3dfb2008a9
parentnet-misc/rclone: metadata - add myself as co-maintainer, add bugs-to (diff)
downloadgentoo-ca3e2c711957b6764efdf7fe7c7342ce97a2da65.tar.gz
gentoo-ca3e2c711957b6764efdf7fe7c7342ce97a2da65.tar.bz2
gentoo-ca3e2c711957b6764efdf7fe7c7342ce97a2da65.zip
net-misc/rclone: bump to 1.66.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
-rw-r--r--net-misc/rclone/Manifest2
-rw-r--r--net-misc/rclone/rclone-1.66.0.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/net-misc/rclone/Manifest b/net-misc/rclone/Manifest
index e9e8b85e7266..d920dc4e4452 100644
--- a/net-misc/rclone/Manifest
+++ b/net-misc/rclone/Manifest
@@ -4,3 +4,5 @@ DIST rclone-1.63.0-deps.tar.xz 297987608 BLAKE2B cfda8663ca32b36f5e56db74a724bde
DIST rclone-1.63.0.tar.gz 16291884 BLAKE2B 540755808dd73fac061c481e2ea4f1ee241bcd55ccabda9b05343f2074f1672868c4246baff42471ecc7000455fe2c2a04c93578faa994aa0323e0033681bb38 SHA512 5f4590a5244d4eb1a51fc15a4ebef70941af94db8790d3ea1bd56b91f399f580b2cd1cc168c5d5e1fd9ee4bc4a3a4a908c8720aead8f8c24bcee3eacc6423ef3
DIST rclone-1.63.1-deps.tar.xz 298002884 BLAKE2B e9dc1dcd3240d4a649b26606109f4ceb9e4e03448da8d27a11c19ed0dc6df39569c3f4714194c3a62e3d80c7a22591ac392d4187df464a4cf203c6135438ec5b SHA512 fff9e6d8ec7721abfd6c95220163478cf1bb3c8fd551a4310641b1213c072ed853e3ca40fd4109ff642d621cc441434f93608af590bb1b07ac2854ddd1d54147
DIST rclone-1.63.1.tar.gz 16294505 BLAKE2B ccb83d5c748f8b68ba7eb7f5910f9b3e8e503407855b4bdd10d5feafaaa96bbf113305cb90952d05922a0ccae6e8efe88737271f4a193cf7a38f79820439c007 SHA512 fff03146ae7de4b47b883576b67852f9ff0558137ecb966300bd357c706d4b71c20ad0f87d0028c90b570d9351024f4ae8ddcce13333df1cabd0e76e08b29063
+DIST rclone-1.66.0-deps.tar.xz 367625224 BLAKE2B 244dc6c77315d1e1038b5e784deb55ca597ce728df34b0619a62ebd40524547a8e12c90f85385bf8515eb69f5cb07d5db6dbcb0de2c7a259edb1d934ce1eb747 SHA512 b238069636da506826deb99ddab869789bf7bda58d4eb47e47101c5011dd35dfd9a39f481f1c874d57a3330fa8b969fed2b98bb1d13ec8e79495f55403cf6001
+DIST rclone-1.66.0.tar.gz 17066102 BLAKE2B 587208635c2154782a9f3285c7972a567625120140d1b43096b572d19ab74ae9c7e12b485d6a74d88f1ef4bbce9656bea8f21c67c641227756dd48856a4da9a7 SHA512 955ed1457ebe7e6ac2288484109ba263601e147f767ce71b70e14ddcf3f97659d90704de094e4e83c0820267e0f41b1950fc3db534bb3577bcf27f0a2401eb84
diff --git a/net-misc/rclone/rclone-1.66.0.ebuild b/net-misc/rclone/rclone-1.66.0.ebuild
new file mode 100644
index 000000000000..87da0231b062
--- /dev/null
+++ b/net-misc/rclone/rclone-1.66.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 check-reqs edo go-module
+
+DESCRIPTION="A program to sync files to and from various cloud storage providers"
+HOMEPAGE="https://rclone.org/
+ https://github.com/rclone/rclone/"
+SRC_URI="
+ https://github.com/rclone/rclone/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
+"
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ sys-fs/fuse:3
+"
+
+CHECKREQS_DISK_BUILD="2500M"
+
+pkg_setup() {
+ check-reqs_pkg_setup
+}
+
+src_compile() {
+ local go_ldflags="
+ -X github.com/rclone/rclone/fs.Version=${PV}
+ "
+ local -a go_buildargs=(
+ -ldflags "${go_ldflags}"
+ -mod=readonly
+ -o ./
+ )
+ ego build "${go_buildargs[@]}" .
+
+ edob ./rclone genautocomplete bash "${PN}.bash"
+ edob ./rclone genautocomplete zsh "${PN}.zsh"
+}
+
+src_test() {
+ # Setting CI skips unreliable tests, see "fstest/testy/testy.go"
+ # "TestAddPlugin" and "TestRemovePlugin" fail.
+ local -x CI="true"
+ local -x RCLONE_CONFIG="/not_found"
+
+ edob go test -mod=readonly -v -run "!Test.*Plugin" ./...
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe "${PN}"
+ doman "${PN}.1"
+
+ newbashcomp "${PN}.bash" "${PN}"
+ insinto /usr/share/zsh/site-functions
+ newins "${PN}.zsh" "_${PN}"
+
+ einstalldocs
+}