summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-02-02 00:36:31 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-02-02 00:36:59 +0100
commitca40e7f56a66c4e59f50c7edc4682f2909004b21 (patch)
treef949b58e5a6814c4c645912aed893ee9b982cfba
parentdev-python/shiboken2: drop 5.15.11 (diff)
downloadgentoo-ca40e7f56a66c4e59f50c7edc4682f2909004b21.tar.gz
gentoo-ca40e7f56a66c4e59f50c7edc4682f2909004b21.tar.bz2
gentoo-ca40e7f56a66c4e59f50c7edc4682f2909004b21.zip
dev-python/pyside2-tools: drop 5.15.11-r1
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-python/pyside2-tools/Manifest1
-rw-r--r--dev-python/pyside2-tools/pyside2-tools-5.15.11-r1.ebuild72
2 files changed, 0 insertions, 73 deletions
diff --git a/dev-python/pyside2-tools/Manifest b/dev-python/pyside2-tools/Manifest
index cc4972e72deb..add932021544 100644
--- a/dev-python/pyside2-tools/Manifest
+++ b/dev-python/pyside2-tools/Manifest
@@ -1,2 +1 @@
-DIST pyside-setup-opensource-src-5.15.11.tar.xz 3584760 BLAKE2B c4d60439a218451eb0c505031524fe1e30a117b7e89a28b5cd7518c193a8d2de01a5db8cb3acdd97c81da6dddff99f786c6c763427f78cdd0af4031122ac2d24 SHA512 377b3f6a793313cf7f5bea0dcef6630bac32d79b247e213d0b1b719805b35692aa8dd9a8896c75c6266f05af38809f574051d64b1a2f958a48c90167feccfb91
DIST pyside-setup-opensource-src-5.15.12.tar.xz 3585204 BLAKE2B a664555b5a98d5ebda39c8226062e12c2b3308e6d95866cd9268de6a8089aef5d0e7a4958821a8e84642f01bffe2a9323ba0752d33fc803d4eb4b29453e2f070 SHA512 843d7352bfb7c9765b5033939b2a6211148ad79a6012685b2d07775745edf04c8420359efb2a3ae4a8686de4daaeb7f531f73fd152f0a2fe7dd54de0080c3cf4
diff --git a/dev-python/pyside2-tools/pyside2-tools-5.15.11-r1.ebuild b/dev-python/pyside2-tools/pyside2-tools-5.15.11-r1.ebuild
deleted file mode 100644
index 22e576b3e256..000000000000
--- a/dev-python/pyside2-tools/pyside2-tools-5.15.11-r1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# TODO: Add PyPy once officially supported. See also:
-# https://bugreports.qt.io/browse/PYSIDE-535
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit cmake python-r1
-
-MY_P=pyside-setup-opensource-src-${PV}
-
-DESCRIPTION="PySide development tools (pyside2-lupdate with support for Python)"
-HOMEPAGE="https://wiki.qt.io/PySide2"
-SRC_URI="https://download.qt.io/official_releases/QtForPython/pyside2/PySide2-${PV}-src/${MY_P}.tar.xz"
-S="${WORKDIR}/${MY_P}/sources/${PN}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- ~dev-python/pyside2-${PV}[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-# the tools conflict with tools from QT
-PATCHES=(
- "${FILESDIR}/${PN}-5.15.11-no-copy-uic.patch"
-)
-
-src_prepare() {
- cmake_src_prepare
-
- python_copy_sources
-}
-
-src_configure() {
- pyside-tools_configure() {
- local mycmakeargs=(
- -DBUILD_TESTS=OFF
- -DPYTHON_CONFIG_SUFFIX="-${EPYTHON}"
- )
- cmake_src_configure
- }
-
- python_foreach_impl pyside-tools_configure
-}
-
-src_compile() {
- pyside-tools_compile() {
- cmake_src_compile
- }
-
- python_foreach_impl pyside-tools_compile
-}
-
-src_install() {
- pyside-tools_install() {
- # This replicates the contents of the PySide6 pypi wheel
- DESTDIR="${BUILD_DIR}" cmake_build install
- dobin "${BUILD_DIR}/usr/bin/pyside2-lupdate"
- python_moduleinto PySide2/scripts
- python_domodule "${BUILD_DIR}/usr/bin/pyside_tool.py"
- }
-
- python_foreach_impl pyside-tools_install
-
- einstalldocs
-}