summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <floss@bsd.ac>2021-06-17 19:49:23 +0200
committerDavid Seifert <soap@gentoo.org>2021-06-17 19:49:23 +0200
commitca40f30da5b003bb6ca24460109f2066fb8035be (patch)
tree336cf4003ec73bf033d01d2245fe89efbc8805e1
parentRevert "sys-apps/portage: 3.0.20-r2 revbump" (diff)
downloadgentoo-ca40f30d.tar.gz
gentoo-ca40f30d.tar.bz2
gentoo-ca40f30d.zip
dev-libs/igraph: version bump to 0.9.4
Closes: https://github.com/gentoo/gentoo/pull/21283 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-libs/igraph/Manifest1
-rw-r--r--dev-libs/igraph/igraph-0.9.4.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/igraph/Manifest b/dev-libs/igraph/Manifest
index 08f741eef1b1..2fd473bbb838 100644
--- a/dev-libs/igraph/Manifest
+++ b/dev-libs/igraph/Manifest
@@ -1,2 +1,3 @@
DIST igraph-0.8.5.tar.gz 3303252 BLAKE2B 9aa920e39a1ef76376eb9a88b6d24e2d051aa22807d4e9bbac49fd1708c59f821d2d4ec55dc96a89de84dfc3ca394e3de9f60704b7f3880a40128863b209d0d6 SHA512 eeb7a21b3a0551e47c178e568811a415e39afb2cc99be39905a15d667fa59564e83979111e1ea5d93636d5b0c7dcbed18728f03aa7ee4d83f96c45af52de8370
DIST igraph-0.9.2.tar.gz 3805091 BLAKE2B aa0e140a9dc8e1005f7f9265aef5880c071fab63c5914c8d93fc7adcbda84d7088678cdb6c277d40bc5998140c70d4a3b359517a4e3583153d1d7233ae8ba42d SHA512 8feb0c23c28e62f1e538fc41917e941f45421060b6240653ee03153b13551c454be019343a314b7913edb9c908518a131034c8e2098d9dd8e5c923fb84d195b3
+DIST igraph-0.9.4.tar.gz 3823988 BLAKE2B c62f15fd227a83da8a78c2bf569874e290c0f8ffd8c69353de1ff2fbd5dff290eceff2462495efc86f44303f3d9d0d397eba720a743da6c118dacb9eeff1b2b8 SHA512 1188d69b95f581d7dac5874dcdb2d1b1a322e39b275c6f092c199ed6214def814062bd46d573bdaa4bc8f4514d6840c6e93dedbe0f6c99a15de33cbc39356573
diff --git a/dev-libs/igraph/igraph-0.9.4.ebuild b/dev-libs/igraph/igraph-0.9.4.ebuild
new file mode 100644
index 000000000000..7d9cab598422
--- /dev/null
+++ b/dev-libs/igraph/igraph-0.9.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Creating and manipulating undirected and directed graphs"
+HOMEPAGE="http://www.igraph.org/"
+SRC_URI="https://github.com/igraph/igraph/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug test threads"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ dev-libs/libxml2
+ sci-libs/arpack
+ sci-libs/cxsparse
+ sci-mathematics/glpk:=
+ virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.9.2-disable-broken-tests.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_CCACHE=OFF
+ -DIGRAPH_GLPK_SUPPORT=ON
+ -DIGRAPH_GRAPHML_SUPPORT=ON
+ -DIGRAPH_USE_INTERNAL_ARPACK=OFF
+ -DIGRAPH_USE_INTERNAL_BLAS=OFF
+ -DIGRAPH_USE_INTERNAL_CXSPARSE=OFF
+ -DIGRAPH_USE_INTERNAL_GLPK=OFF
+ -DIGRAPH_USE_INTERNAL_GMP=OFF
+ -DIGRAPH_USE_INTERNAL_LAPACK=OFF
+ -DIGRAPH_ENABLE_TLS=$(usex threads)
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ cmake_build check
+}