summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-07 07:27:17 +0000
committerSam James <sam@gentoo.org>2022-03-07 07:30:47 +0000
commitca438a261864a6ec6eac15cbf3f95fcb6b694593 (patch)
tree1a2ccdc5c733df64fec4c3f8a2620e35cb43cea2
parentdev-qt/qtvirtualkeyboard: x86 stable wrt bug #833118 (diff)
downloadgentoo-ca438a261864a6ec6eac15cbf3f95fcb6b694593.tar.gz
gentoo-ca438a261864a6ec6eac15cbf3f95fcb6b694593.tar.bz2
gentoo-ca438a261864a6ec6eac15cbf3f95fcb6b694593.zip
net-libs/libtorrent-rasterbar: drop broken USE=gnutls
Produces underlinked Python bindings which breaks Deluge. Everyone else seems to build with OpenSSL anyway. (Had numerous reports of this on IRC and on the forums, as well as on Bugzilla). Closes: https://bugs.gentoo.org/830846 See: https://forums.gentoo.org/viewtopic-t-1146607.html Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.5-r1.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.5-r1.ebuild b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.5-r1.ebuild
new file mode 100644
index 000000000000..fab89d6e9c77
--- /dev/null
+++ b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.5-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit cmake python-single-r1
+
+DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
+HOMEPAGE="https://libtorrent.org/ https://github.com/arvidn/libtorrent"
+SRC_URI="https://github.com/arvidn/libtorrent/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/2.0"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc x86"
+# gnutls removed because totally broken with at least Python bindings: bug #830846
+# (they expect openssl?)
+IUSE="+dht debug python ssl test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/boost:=[threads(+)]
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-libs/boost[python,${PYTHON_USEDEP}]
+ ')
+ )
+ ssl? ( dev-libs/openssl:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="python? (
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ')
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-boost-1.78.patch"
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_CXX_STANDARD=17
+ -DBUILD_SHARED_LIBS=ON
+ -Dbuild_examples=OFF
+ -Ddht=$(usex dht ON OFF)
+ -Dencryption=$(usex ssl ON OFF)
+ -Dgnutls=OFF
+ -Dlogging=$(usex debug ON OFF)
+ -Dpython-bindings=$(usex python ON OFF)
+ -Dbuild_tests=$(usex test ON OFF)
+ )
+
+ # We need to drop the . from the Python version to satisfy Boost's
+ # FindBoost.cmake module, bug #793038.
+ use python && mycmakeargs+=( -Dboost-python-module-name="${EPYTHON/./}" )
+
+ cmake_src_configure
+}
+
+src_test() {
+ local myctestargs=(
+ # Needs running UPnP server
+ -E "test_upnp"
+ )
+
+ # Checked out Fedora's test workarounds for inspiration
+ # https://src.fedoraproject.org/rpms/rb_libtorrent/blob/rawhide/f/rb_libtorrent.spec#_120
+ LD_LIBRARY_PATH="${BUILD_DIR}:${LD_LIBRARY_PATH}" cmake_src_test
+}