summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-31 16:25:39 +0100
committerMichał Górny <mgorny@gentoo.org>2022-10-31 16:49:15 +0100
commitca5e0acb91cde33aeb3443463718437789ce17af (patch)
treeaf555cc8c4318753e4b4e76011ed7401db0b028b
parentdev-python/yappi: Bump to 1.4.0 (diff)
downloadgentoo-ca5e0acb.tar.gz
gentoo-ca5e0acb.tar.bz2
gentoo-ca5e0acb.zip
dev-python/regex: Bump to 2022.10.31
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/regex/Manifest1
-rw-r--r--dev-python/regex/regex-2022.10.31.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/regex/Manifest b/dev-python/regex/Manifest
index 13dc4662993a..515f71eea275 100644
--- a/dev-python/regex/Manifest
+++ b/dev-python/regex/Manifest
@@ -1 +1,2 @@
+DIST regex-2022.10.31.tar.gz 391554 BLAKE2B 060822767ab28e26d000faa198f4226ba1e4600141a7b3e0f656df8d004b5007a0a7934057e608d524f6a21421573fbeb8a1be208ce69ba2d912a55d19fb3f22 SHA512 d461cddea75f2a8ceb749d7e1a54f3543fe4cb3418976ded26101cb53c333f0e2eabaa824239c89c50c94c6736409566215cb7b6c6c3a0544678d10b6af76cc5
DIST regex-2022.9.13.tar.gz 391531 BLAKE2B 83e8f1aabe15e65fb4f96072be3ccd5ddf1dcbffeeecb9d7a2889fb910d4095e902bfd45f43184b0df115b1116ddfc3e67d68a2fa903f19a8cbc6844ce023a3b SHA512 a991d6358001297db2b57855e76b8de680941ddefe9d18af1e9ee033da4e519df7b4553d138e7adf32b30593290284c91a954363bcc30b215409efe121e41e69
diff --git a/dev-python/regex/regex-2022.10.31.ebuild b/dev-python/regex/regex-2022.10.31.ebuild
new file mode 100644
index 000000000000..d864a4bd8ea3
--- /dev/null
+++ b/dev-python/regex/regex-2022.10.31.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Alternative regular expression module to replace re"
+HOMEPAGE="
+ https://bitbucket.org/mrabarnett/mrab-regex/
+ https://pypi.org/project/regex/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="doc"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2021.4.4-pypy3-fix-test_empty_array.patch"
+ "${FILESDIR}/${PN}-2021.4.4-pypy3-fix-test_issue_18468.patch"
+)
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/Features.html )
+ local DOCS=( README.rst docs/*.rst )
+
+ distutils-r1_python_install_all
+}