summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-30 06:53:17 +0100
committerMichał Górny <mgorny@gentoo.org>2022-10-30 07:38:46 +0100
commitca7e2e6f3fab6aa1be87c4f5dc60f7cd8a6fc806 (patch)
tree3a03d7f52f5584403b4fb336faca86eedb9fc091
parentdev-python/zstandard: Bump to 0.19.0 (diff)
downloadgentoo-ca7e2e6f.tar.gz
gentoo-ca7e2e6f.tar.bz2
gentoo-ca7e2e6f.zip
dev-cpp/rapidfuzz-cpp: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-cpp/rapidfuzz-cpp/Manifest2
-rw-r--r--dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-1.7.0.ebuild42
-rw-r--r--dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-1.8.0.ebuild42
3 files changed, 0 insertions, 86 deletions
diff --git a/dev-cpp/rapidfuzz-cpp/Manifest b/dev-cpp/rapidfuzz-cpp/Manifest
index 4e7aaa9035db..900a346f34ac 100644
--- a/dev-cpp/rapidfuzz-cpp/Manifest
+++ b/dev-cpp/rapidfuzz-cpp/Manifest
@@ -1,3 +1 @@
-DIST rapidfuzz-cpp-1.7.0.gh.tar.gz 252646 BLAKE2B 5d79c07e26b6bb8e84d3280c3401bad60a3ca9846977a5bf9b13787ed7951c3805c71b7e6e2e03b14e2b988381484d969e1cc885c316bcb805b403e53332b31b SHA512 ed8af678a40161aa738bd3606b41fd54c1dba603c47fbdb1182527abd5667736e50f458af252e7bde954f263040cdbd662ad1c6be0a5caa5289f0a351dfd6d9e
-DIST rapidfuzz-cpp-1.8.0.gh.tar.gz 280419 BLAKE2B ae6b7694df3f8ba97b369608bb02783bdd48572e80a9d4f0ee51585975aaee1c0ee058862b94a7a8e46f835b03c04d134143ed07fb5c6d412b4b5cff8686c6d3 SHA512 35729c90494b419fefd9c6bbd03e42cc485d421defcd65bf5dee776d4d0756318a90456980914ccebc100b1bb388474db54638a8628efd496764c604d6221688
DIST rapidfuzz-cpp-1.9.0.gh.tar.gz 281385 BLAKE2B 4afc48edd9c8270200645eb77065bf212b9579b90b3916e261bbe69fd60f67c1e510c3ae4ef9877a26c3313063717b362e01c6cf799a0f9fc3429799d9b2dca6 SHA512 d95c90f9118811d650d859a20f847c71427acbc8c4f907f49d23b069cd6d1a848749d32f8fbff7326828b7a030c3f488acacba5845a72a0057ccf4c3088badf4
diff --git a/dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-1.7.0.ebuild b/dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-1.7.0.ebuild
deleted file mode 100644
index 99e66055cc0f..000000000000
--- a/dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-1.7.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Rapid fuzzy string matching in C++"
-HOMEPAGE="https://github.com/maxbachmann/rapidfuzz-cpp/"
-SRC_URI="
- https://github.com/maxbachmann/rapidfuzz-cpp/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- test? (
- >=dev-cpp/catch-3
- )
-"
-
-src_prepare() {
- # apparently "C++ best practices" don't mind fetching random stuff
- # at build time
- sed -i -e '/aminya/,/^)/d' test/CMakeLists.txt || die
- find -name 'CMakeLists.txt' -exec \
- sed -i -e 's:project_warnings::' {} + || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DRAPIDFUZZ_BUILD_TESTING=$(usex test)
- )
- cmake_src_configure
-}
diff --git a/dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-1.8.0.ebuild b/dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-1.8.0.ebuild
deleted file mode 100644
index 6fb280d52d37..000000000000
--- a/dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-1.8.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Rapid fuzzy string matching in C++"
-HOMEPAGE="https://github.com/maxbachmann/rapidfuzz-cpp/"
-SRC_URI="
- https://github.com/maxbachmann/rapidfuzz-cpp/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- test? (
- >=dev-cpp/catch-3
- )
-"
-
-src_prepare() {
- # apparently "C++ best practices" don't mind fetching random stuff
- # at build time
- sed -i -e '/aminya/,/^)/d' test/CMakeLists.txt || die
- find -name 'CMakeLists.txt' -exec \
- sed -i -e 's:project_warnings::' {} + || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DRAPIDFUZZ_BUILD_TESTING=$(usex test)
- )
- cmake_src_configure
-}