summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-20 12:17:17 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-20 14:18:27 +0200
commitcaa1d73c12badf335753224e71b4f18f486ac7e2 (patch)
tree60c9d012f7278b5a9776ceda7311c8d3211a1c54
parentdev-python/sphinxcontrib-serializinghtml: EAPI 8, PEP517, rm namespace dep (diff)
downloadgentoo-caa1d73c12badf335753224e71b4f18f486ac7e2.tar.gz
gentoo-caa1d73c12badf335753224e71b4f18f486ac7e2.tar.bz2
gentoo-caa1d73c12badf335753224e71b4f18f486ac7e2.zip
dev-python/sphinxcontrib-spelling: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinxcontrib-spelling/Manifest1
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.3.1.ebuild48
2 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/sphinxcontrib-spelling/Manifest b/dev-python/sphinxcontrib-spelling/Manifest
index c3660d42ec16..b5915e95e87a 100644
--- a/dev-python/sphinxcontrib-spelling/Manifest
+++ b/dev-python/sphinxcontrib-spelling/Manifest
@@ -1,2 +1 @@
-DIST sphinxcontrib-spelling-7.3.1.tar.gz 51104 BLAKE2B 8d757b492ce5bcb103bc604923da928f0440d4d0b882743d14b60fef21cfb423ea93a1e79f309b7cf27e8385ac94c01b24163a17407609ee20b9ec82dff63f62 SHA512 53f2532ff31a82c1cf568400a6066f319da3331c960446478bcd37e9293f4d080061b9c4914ac308e89878f432b6573ff782c5faba0f557384da55f202e68479
DIST sphinxcontrib-spelling-7.3.2.tar.gz 51813 BLAKE2B 7c96f3b102fa33ea4d9e35100930a157200a1c01c51d8ec5145c45c5a24e3b5de35f6c4669177363c6098cb96275e10c39ff660c36d209cb6fa658e50cb8e169 SHA512 043a50f694366de4a3aedc24ca2ea7d89c85087097264f4e4fc860f68a3df5a67f19ec7172e4a67074377846d013d24edecd751885136c7263bc30b034c0f0e9
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.3.1.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.3.1.ebuild
deleted file mode 100644
index f082f7df02a2..000000000000
--- a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.3.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Sphinx spelling extension"
-HOMEPAGE="https://github.com/sphinx-contrib/spelling"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-python/pyenchant[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/pbr[${PYTHON_USEDEP}]
- test? (
- app-dicts/myspell-en
- )
-"
-
-# The doc can only be built from a git repository
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # requires the git repo
- tests/test_filter.py::test_contributors
- # fails when started via "python -m pytest"
- "tests/test_filter.py::test_importable_module_skip[__main__-False]"
-)
-
-# We don't want distutils_enable_tests to add the namespace
-# package to BDEPEND under "test?". Therefore we add it to RDEPEND
-# after running distutils_enable_tests.
-RDEPEND+="
- dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
-"
-
-python_install_all() {
- distutils-r1_python_install_all
- find "${ED}" -name '*.pth' -delete || die
-}