summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiezhiko <Miezhiko@gmail.com>2023-06-15 15:39:26 +0400
committerAlfredo Tupone <tupone@gentoo.org>2023-06-15 20:04:49 +0200
commitcab6080ccacbf3110f24985691ff2d871853b545 (patch)
treefb0694591d4425be3d8666684ae3e9cd45498448
parentsys-firmware/intel-microcode: drop versions (diff)
downloadgentoo-cab6080ccacbf3110f24985691ff2d871853b545.tar.gz
gentoo-cab6080ccacbf3110f24985691ff2d871853b545.tar.bz2
gentoo-cab6080ccacbf3110f24985691ff2d871853b545.zip
sci-libs/huggingface_hub: 0.15.1
Signed-off-by: Miezhiko <Miezhiko@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31452 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--sci-libs/huggingface_hub/Manifest1
-rw-r--r--sci-libs/huggingface_hub/huggingface_hub-0.15.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/sci-libs/huggingface_hub/Manifest b/sci-libs/huggingface_hub/Manifest
index 1caa5dc407e5..a90258dbb40b 100644
--- a/sci-libs/huggingface_hub/Manifest
+++ b/sci-libs/huggingface_hub/Manifest
@@ -1,2 +1,3 @@
DIST huggingface_hub-0.13.4.gh.tar.gz 325227 BLAKE2B 56ad70072ddd7f9878de4db45fffeb200032d71ba36fa2dc0e81d50a079a5ffa9ad80b3a71773a5fe466ac4522db7061fc7974149092d212278b8159d30e212b SHA512 6c07c1dc1a0c327ca463b7f366c265dfc7e55ed69592df5ad10f6d77956ac1dfe3e1f827a2df200f943da2f34a96ba4de1c395944b542e3d7142d925f60ad274
DIST huggingface_hub-0.14.1.gh.tar.gz 359222 BLAKE2B 379cc49230f2e8f5f57d0dac5cfab60f9d0a7d04bab36af8ba0a77846fdf6eea412f9d473bd2f554a912a862747156fe29d36913691b6df8c3cf769389d86b3f SHA512 8d1e9c3e77a8ddb4a6b1827751fad95baad7504a1ad2cdf443f1cf64cff10e1cea9148f2076e0fd462c7f1ce860230e919059e61807260368727a6bd5e9efeb3
+DIST huggingface_hub-0.15.1.gh.tar.gz 1222091 BLAKE2B f9b452f7ffe54d6edfe87e288cd52ee2ec35450ffe052d59442859918b4e1baf93d2d807dc54799ea3346bf00f52ad75bbb9dab69f36771ba8bf8702d54bbe7e SHA512 70d3a47383aa6a0c3cc1b13f1bf3e69326c3432eca8e68ea08f991aa2c5a212f1e4fe262840129bb64dc9ccb3f958371ea7a38ff5246f14585783bafa3d81585
diff --git a/sci-libs/huggingface_hub/huggingface_hub-0.15.1.ebuild b/sci-libs/huggingface_hub/huggingface_hub-0.15.1.ebuild
new file mode 100644
index 000000000000..7c519b339f79
--- /dev/null
+++ b/sci-libs/huggingface_hub/huggingface_hub-0.15.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="a client library to interact with the Hugging Face Hub"
+HOMEPAGE="
+ https://pypi.org/project/huggingface_hub/
+"
+SRC_URI="https://github.com/huggingface/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" #Several modules not yet packaged
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest