summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 09:16:31 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:11:03 +0100
commitcadba19a261a0978e0aa15ebb000db4ffb34760c (patch)
tree08cae6d0503d4e52c2b21a3b79aa85be877f459e
parentnet-libs/openmq-cclient: respect PKG_CONFIG (diff)
downloadgentoo-cadba19a261a0978e0aa15ebb000db4ffb34760c.tar.gz
gentoo-cadba19a261a0978e0aa15ebb000db4ffb34760c.tar.bz2
gentoo-cadba19a261a0978e0aa15ebb000db4ffb34760c.zip
sci-geosciences/gpscorrelate: respect PKG_CONFIG
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-geosciences/gpscorrelate/files/gpscorrelate-1.6.1-makefile.patch17
-rw-r--r--sci-geosciences/gpscorrelate/gpscorrelate-1.6.1-r2.ebuild2
2 files changed, 9 insertions, 10 deletions
diff --git a/sci-geosciences/gpscorrelate/files/gpscorrelate-1.6.1-makefile.patch b/sci-geosciences/gpscorrelate/files/gpscorrelate-1.6.1-makefile.patch
index f48dba1882f2..82bd63545dfc 100644
--- a/sci-geosciences/gpscorrelate/files/gpscorrelate-1.6.1-makefile.patch
+++ b/sci-geosciences/gpscorrelate/files/gpscorrelate-1.6.1-makefile.patch
@@ -1,6 +1,5 @@
-diff -urN gpscorrelate-1.6.1.old/Makefile gpscorrelate-1.6.1/Makefile
---- gpscorrelate-1.6.1.old/Makefile 2011-06-08 13:51:06.000000000 +0200
-+++ gpscorrelate-1.6.1/Makefile 2011-06-08 14:13:18.000000000 +0200
+--- a/Makefile
++++ b/Makefile
@@ -4,11 +4,15 @@
COBJS = main-command.o unixtime.o gpx-read.o correlate.o exif-gps.o
@@ -10,13 +9,13 @@ diff -urN gpscorrelate-1.6.1.old/Makefile gpscorrelate-1.6.1/Makefile
-OFLAGS = -Wall
-override OFLAGS += $(shell pkg-config --libs libxml-2.0 gtk+-2.0) -lm -lexiv2
-prefix = /usr/local
-+CFLAGS += $(shell pkg-config --cflags libxml-2.0) -I/usr/include/exiv2
-+CXXFLAGS += $(shell pkg-config --cflags libxml-2.0) -I/usr/include/exiv2
-+CLIBS = $(shell pkg-config --libs libxml-2.0) -lm -lexiv2 -lstdc++
++CFLAGS += $(shell ${PKG_CONFIG} --cflags libxml-2.0) -I/usr/include/exiv2
++CXXFLAGS += $(shell ${PKG_CONFIG} --cflags libxml-2.0) -I/usr/include/exiv2
++CLIBS = $(shell ${PKG_CONFIG} --libs libxml-2.0) -lm -lexiv2 -lstdc++
+ifdef BUILD_GUI
-+CXXFLAGS += $(shell pkg-config --cflags gtk+-2.0)
-+CFLAGS += $(shell pkg-config --cflags gtk+-2.0)
-+CLIBS += $(shell pkg-config --libs gtk+-2.0)
++CXXFLAGS += $(shell ${PKG_CONFIG} --cflags gtk+-2.0)
++CFLAGS += $(shell ${PKG_CONFIG} --cflags gtk+-2.0)
++CLIBS += $(shell ${PKG_CONFIG} --libs gtk+-2.0)
+endif
+prefix ?= /usr/local
bindir = $(prefix)/bin
diff --git a/sci-geosciences/gpscorrelate/gpscorrelate-1.6.1-r2.ebuild b/sci-geosciences/gpscorrelate/gpscorrelate-1.6.1-r2.ebuild
index edc3ab6c0635..7f1c8c38fc5e 100644
--- a/sci-geosciences/gpscorrelate/gpscorrelate-1.6.1-r2.ebuild
+++ b/sci-geosciences/gpscorrelate/gpscorrelate-1.6.1-r2.ebuild
@@ -32,7 +32,7 @@ PATCHES=(
)
src_compile() {
- tc-export CC CXX
+ tc-export CC CXX PKG_CONFIG
local opts="gpscorrelate gpscorrelate.1"
use gtk && opts+=" gpscorrelate-gui BUILD_GUI=1"
emake ${opts}