summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2022-09-26 18:18:30 -0300
committerMatt Turner <mattst88@gentoo.org>2022-09-27 11:44:24 -0400
commitcae6a47fffe16fed88b336e93e4a8ae48b5ce064 (patch)
treec42ab8c5784b1aafc43748d538b4f05dd3d8c062
parentnet-libs/webkit-gtk: Version bump to 2.38.0 (diff)
downloadgentoo-cae6a47fffe.tar.gz
gentoo-cae6a47fffe.tar.bz2
gentoo-cae6a47fffe.zip
gnome-base/dconf-editor: Version bump to 43.0
Closes: https://github.com/gentoo/gentoo/pull/27493 Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--gnome-base/dconf-editor/Manifest1
-rw-r--r--gnome-base/dconf-editor/dconf-editor-43.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/gnome-base/dconf-editor/Manifest b/gnome-base/dconf-editor/Manifest
index 75ca3cf1323f..af599cac9917 100644
--- a/gnome-base/dconf-editor/Manifest
+++ b/gnome-base/dconf-editor/Manifest
@@ -1 +1,2 @@
DIST dconf-editor-3.38.3.tar.xz 594544 BLAKE2B 0455fc01be96bccec9a9799c5bf23e9fe58cb34d32899a119753f58f5bc2f03acb96ff0eeba131cd8c0ea130e3afad16e4fadb23601510b618bf7a3d5a1664a3 SHA512 cf00705c1e11eab980777b9696fbaaa0f5f8a8118276f2add4f4fcefe5aab46844a539539418ce61f285e65623179a9d63cc18a91339b70b5e7c9408c697e9d1
+DIST dconf-editor-43.0.tar.xz 598496 BLAKE2B 16b39289f822075a951514c44c5b5d673dd5c6d7e4f043f8005098a51209513c88a16846a7bb8988696775ad4f44162080edec59e3dfe2402a814573ff4efe85 SHA512 d13d32a982164e6991576039dda54d51508fc56e1119def9b89ca498ac111c98f144309cab42e45d5b77130d4d7d8fa23168865c604cbaf55da4e6ed3d451953
diff --git a/gnome-base/dconf-editor/dconf-editor-43.0.ebuild b/gnome-base/dconf-editor/dconf-editor-43.0.ebuild
new file mode 100644
index 000000000000..4e93007b67a5
--- /dev/null
+++ b/gnome-base/dconf-editor/dconf-editor-43.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Graphical tool for editing the dconf configuration database"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/dconf-editor"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x86-linux"
+
+RDEPEND="
+ >=gnome-base/dconf-0.26.1
+ >=dev-libs/glib-2.55.1:2
+ >=x11-libs/gtk+-3.22.27:3
+ >=gui-libs/libhandy-1.6.0:1
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(vala_depend)
+ dev-libs/libxml2:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}