summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-09-29 21:01:36 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-09-29 22:07:06 +0200
commitcb03fa2ffb85e396b804edcd716f9191fd00cc70 (patch)
tree99d3264a5cab80f4c3a67d56855a11f06970bdd8
parentapp-office/libreoffice-l10n: Drop 6.3.1.2 (diff)
downloadgentoo-cb03fa2f.tar.gz
gentoo-cb03fa2f.tar.bz2
gentoo-cb03fa2f.zip
dev-libs/sink: 0.8.0 version bump
Sigh... if upstream will not bless us with a release... Closes: https://bugs.gentoo.org/693988 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-libs/sink/Manifest1
-rw-r--r--dev-libs/sink/sink-0.8.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-libs/sink/Manifest b/dev-libs/sink/Manifest
index 25227f56723f..7be40474d163 100644
--- a/dev-libs/sink/Manifest
+++ b/dev-libs/sink/Manifest
@@ -1 +1,2 @@
DIST sink-0.7.0.tar.gz 383090 BLAKE2B b853609889ead6f623c7288b9dfe8dba0388dc0d5e8f28d9967fa9be1d78b10bafd9d4674f11355bfe60506843d2abe033149c448ff293329db558ed00fef18b SHA512 591838cb9c76d89c1794b94b02bff3d67155e1f27ae32b7ac9369d15aa109130c7792f30e74b61009765e7b7cb78141bf5e3c93304d814bce22bf91059339fd0
+DIST sink-0.8.0.tar.gz 409901 BLAKE2B bf66b00855333ee5a35471968a09a4bab161ea0b765389f1f1291965e318d65da5532335dff033675e38eb302755fba250b1d3b617b4a54b2fca6c4385182956 SHA512 d3fcc9e502996e8730ca372370a9be5e3ff2ffe79e02595a9a02aab281c17f223c435bd7f3c992d11139c272350d1e3ddb7f3a4d18f46ba513465c41c5075cbc
diff --git a/dev-libs/sink/sink-0.8.0.ebuild b/dev-libs/sink/sink-0.8.0.ebuild
new file mode 100644
index 000000000000..09e0228f9d81
--- /dev/null
+++ b/dev-libs/sink/sink-0.8.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="false" # build breaks otherwise. tests not isolated.
+inherit kde5
+
+DESCRIPTION="Data access layer handling synchronization, caching and indexing"
+SRC_URI="https://github.com/KDE/sink/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64"
+IUSE=""
+
+# qtgui is bogus but is required because something else in the deptree
+# uses it as a public dependency but doesn't search for it properly
+RDEPEND="
+ || (
+ $(add_frameworks_dep kcalendarcore)
+ $(add_kdeapps_dep kcalcore)
+ )
+ || (
+ $(add_frameworks_dep kcontacts)
+ $(add_kdeapps_dep kcontacts)
+ )
+ $(add_frameworks_dep kcoreaddons)
+ $(add_kdeapps_dep kmime)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ dev-db/lmdb:=
+ dev-libs/flatbuffers
+ >=dev-libs/kasync-0.3
+ >=dev-libs/xapian-1.4.4:0=
+ >=net-libs/kdav2-0.3
+ >=net-libs/kimap2-0.3
+ net-misc/curl
+ sys-libs/readline:0=
+"
+DEPEND="${RDEPEND}
+ $(add_qt_dep qtconcurrent)
+"
+
+# fails to build
+RESTRICT+=" test"
+
+src_prepare() {
+ kde5_src_prepare
+ # FIXME: sink is useless without its 'examples'. Workaround our eclass
+ sed -i -e "/add_subdirectory(examples)/ s/#DONOTCOMPILE //" \
+ CMakeLists.txt || die "Failed to fix CMakeLists.txt"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libgit2=ON
+ )
+ kde5_src_configure
+}