summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-05-19 15:39:02 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-05-19 16:18:01 +0200
commitcb0c96e7157e5b2c552edf359ca008d9181c86da (patch)
tree8bf88ccfb3bb3fd07e1ce1a9b9bbc020cbfa246f
parentapp-emacs/editorconfig-emacs: bump to 0.10.1 (diff)
downloadgentoo-cb0c96e7157e5b2c552edf359ca008d9181c86da.tar.gz
gentoo-cb0c96e7157e5b2c552edf359ca008d9181c86da.tar.bz2
gentoo-cb0c96e7157e5b2c552edf359ca008d9181c86da.zip
app-emacs/macrostep: bump to 0.9.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/macrostep/Manifest1
-rw-r--r--app-emacs/macrostep/macrostep-0.9.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/macrostep/Manifest b/app-emacs/macrostep/Manifest
index 561c33eb809e..d9363a3740d2 100644
--- a/app-emacs/macrostep/Manifest
+++ b/app-emacs/macrostep/Manifest
@@ -1 +1,2 @@
DIST macrostep-0.9.1.tar.gz 32980 BLAKE2B b2949041ab8e6e894046b1be84a223880544f5432606b229fca5a348cca605112d63837587a55654a64971d97e48b063d8cdf4bf1c3f01b23f1db168eb350dbb SHA512 8e6af8040694371958314ca94ec1fbc7a309f82eaa4fd05333e0d16c369d9342d90c86153ce3890b7dfb12567d69526cfb8a2aa5452f4f53dc9497d92ae08aac
+DIST macrostep-0.9.2.tar.gz 33067 BLAKE2B 0fd25c8ae8827032286890040dadc2f3f2ca20d2fb5366acfe0a6a319f4dc20e2ff17fb59355b2bab36a9cea418122f5c3ae1485bc2ea9989f9c7c5fe4e4b390 SHA512 55d4c0c09f184a3e2218dc484d3c0f57255d591db910082d466f835b084aaa5d795636d337fa1f642a9a97858eaef63b58771f5583c975488f07ed0f87bdbb32
diff --git a/app-emacs/macrostep/macrostep-0.9.2.ebuild b/app-emacs/macrostep/macrostep-0.9.2.ebuild
new file mode 100644
index 000000000000..c24309d913e4
--- /dev/null
+++ b/app-emacs/macrostep/macrostep-0.9.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Interactive macro-expander for Emacs"
+HOMEPAGE="https://github.com/joddie/macrostep/
+ https://github.com/emacsorphanage/macrostep/"
+SRC_URI="https://github.com/emacsorphanage/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=( "${FILESDIR}"/${PN}-test.patch )
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . --load ${PN}-test.el || die "test failed"
+}
+
+src_install() {
+ rm macrostep-test.el{,c} || die
+
+ elisp_src_install
+}