summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-07 08:00:43 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-07 09:27:41 +0200
commitcb0f660d806c7133cb02d36cb965ab5b43ef898b (patch)
tree43035940564d0c1e575b729ab4c14b45fa38a229
parentdev-python/boto3: Bump to 1.15.13 (diff)
downloadgentoo-cb0f660d.tar.gz
gentoo-cb0f660d.tar.bz2
gentoo-cb0f660d.zip
dev-python/cfn-python-lint: Bump to 0.37.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cfn-python-lint/Manifest1
-rw-r--r--dev-python/cfn-python-lint/cfn-python-lint-0.37.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/cfn-python-lint/Manifest b/dev-python/cfn-python-lint/Manifest
index 6ae521128a7e..3a7d24071751 100644
--- a/dev-python/cfn-python-lint/Manifest
+++ b/dev-python/cfn-python-lint/Manifest
@@ -3,3 +3,4 @@ DIST cfn-python-lint-0.35.1.tar.gz 4501826 BLAKE2B 84da0965fc198ce7b8f955a7d43f9
DIST cfn-python-lint-0.36.0.tar.gz 4879599 BLAKE2B a79a12290e20f4db1e45b29df0486d3b69f3c028f35cae8e8ba9ab5da191c1a5f7fed6bc339d24e3212faab7a05a82e859a79135847eb90b0161fe0aa7b8c995 SHA512 286c8e614ee083981105a74f09b4c75454ae6eef48812ac59852374bea5dfc0d111b006bb67c50e42fa2a1eeb54ce6f25b8bf0f06624da236344e9bbadf4ce1c
DIST cfn-python-lint-0.36.1.tar.gz 4963743 BLAKE2B 31efc227bf2b5aafff0365d0ca949e4007684dd896e6e8a75afb692a260e05f6b134b9cc822855c99edec7398a1cdd767a71557ef7178ff9054c4e737a5a5ec5 SHA512 4682b7a010875df2322856e9a01aa547fcce171c5bb7531ee35d92bcf0cfc523f78b4180fcc6a6c4a1460d5b517e834ce0e0026fa6c2f6afb9ebf3b3c46434bd
DIST cfn-python-lint-0.37.0.tar.gz 4990073 BLAKE2B 447e7685f5ae7d4a610512729d2ecda48f4838f2b2f22ae80cdfef53d52cd929953014f2f2779ca7d340ed88287bf6b4f221e3be3b69b10335fb6716104f44ca SHA512 4ef0763c0995baf196098aa1499b22400cf5fd44f1f519d391314c6e199091a22b2179d1b1cabae6cddc27a85673c294fc65c02b92d864a9546ceb5c42264590
+DIST cfn-python-lint-0.37.1.tar.gz 5005775 BLAKE2B f393f4b871a8782e81f71a1a2d011d5d59dee287fa305d1b6c82ac366e7975e5ff02ce96949501ed883c2b86cc6547d148d19d5153bf1b77a675a1b8c33ba96d SHA512 8e2d3419142527431835f935f96bea972057eb471894ddc2b3867ce3cbe490d540fe9b1490b79c84042eba8e5f997cab1aae5aff862aaefeda38351babb04a2f
diff --git a/dev-python/cfn-python-lint/cfn-python-lint-0.37.1.ebuild b/dev-python/cfn-python-lint/cfn-python-lint-0.37.1.ebuild
new file mode 100644
index 000000000000..09f91de4ad66
--- /dev/null
+++ b/dev-python/cfn-python-lint/cfn-python-lint-0.37.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="https://pypi.org/project/cfn-lint/ https://github.com/aws-cloudformation/cfn-python-lint"
+SRC_URI="https://github.com/aws-cloudformation/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.25.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_resources[${PYTHON_USEDEP}]
+ ' python3_6)
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.11[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/cfn-python-lint-0.30.1-tests.patch"
+)
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ distutils_install_for_testing
+ "${EPYTHON}" -m unittest discover -v ||
+ die "tests fail with ${EPYTHON}"
+}