summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-12 06:45:31 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-12 06:45:31 +0100
commitcb100453d7f0d20ad63bee697dec47c09cdbfee5 (patch)
tree19bc38fe0498b396ecbdbe220b8cec62cab90560
parentdev-python/pypy3: Install pregenerated sysconfigdata (diff)
downloadgentoo-cb100453d7f0d20ad63bee697dec47c09cdbfee5.tar.gz
gentoo-cb100453d7f0d20ad63bee697dec47c09cdbfee5.tar.bz2
gentoo-cb100453d7f0d20ad63bee697dec47c09cdbfee5.zip
dev-python/gpep517: Bump to v13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/gpep517/Manifest1
-rw-r--r--dev-python/gpep517/gpep517-13.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/gpep517/Manifest b/dev-python/gpep517/Manifest
index 1bb19aaac485..a66e4a639b10 100644
--- a/dev-python/gpep517/Manifest
+++ b/dev-python/gpep517/Manifest
@@ -1,2 +1,3 @@
DIST gpep517-11.gh.tar.gz 15344 BLAKE2B 14f3f4b284eb4f7de8a78a9215cf2ec7fc84cb4028d83555b595a245d5ff2eb78be5049b30ccca944c35c40db0cc61e1afeaa68b25a0d6f3608363af75059762 SHA512 5ce840841d99c20d62b5b6c8dcb6ec353e40c75537aa99e44fa7dc13bff37444cd66d4cbc97eb1b107b6df85edfda853343d5e8ef1865d0d5ccd293c1496b5c0
DIST gpep517-12.gh.tar.gz 17304 BLAKE2B c4a1ff1bf67866c2776efeab8c3f678272fcbd2dd69359b97420e280b58ce8549c6bf7e497ca13816ed89b296a44f99c7aa99f9783a9cd2d940aec5b29cdcbe1 SHA512 a0f40e9c12d711ff2e5fc3f8ca84c6687d6b39cdc420364e3846b32804dd8f98a5d09c0aaa7948b90b3b115f829dc4e767a65bbe8bc2e682f11fd6ba8757a59e
+DIST gpep517-13.gh.tar.gz 17197 BLAKE2B eb2f1061c0d762ec5cedf042c41a04eb1ddfbb146b5d81727f7e09d55e76323ee4ffb00e8a8c17a8d423b863bd46dc79a03048da1998cf50fee45bc75c64f38e SHA512 23219a3f7369def01e41fe6bbf96400cc85bb6f5efae3924451a5f3dbed0c9a5e7bb69aa1810897597aa248aa64fc6445fb32ed5bf314d0265c5339893ea58e3
diff --git a/dev-python/gpep517/gpep517-13.ebuild b/dev-python/gpep517/gpep517-13.ebuild
new file mode 100644
index 000000000000..5cd8e4b1d379
--- /dev/null
+++ b/dev-python/gpep517/gpep517-13.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=no
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A backend script to aid installing Python packages in Gentoo"
+HOMEPAGE="
+ https://pypi.org/project/gpep517/
+ https://github.com/projg2/gpep517/
+"
+SRC_URI="
+ https://github.com/projg2/gpep517/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-python/installer-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.2.3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_install() {
+ python_domodule gpep517
+ python_newscript - gpep517 <<-EOF
+ #!${EPREFIX}/usr/bin/python
+ import sys
+ from gpep517.__main__ import main
+ sys.exit(main())
+ EOF
+}