summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-02-24 13:31:14 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-02-24 13:31:34 +0100
commitcb1575bf255ed4af7ed914683f4349819fec0370 (patch)
tree8fdd9cf416d5aa337500e45edc21b2d39661bbb5
parentapp-text/lcdf-typetools: bump to 2.107 (diff)
downloadgentoo-cb1575bf.tar.gz
gentoo-cb1575bf.tar.bz2
gentoo-cb1575bf.zip
dev-python/pid: bump to 2.2.0, add test deps and more python compat
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--dev-python/pid/Manifest1
-rw-r--r--dev-python/pid/pid-2.2.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pid/Manifest b/dev-python/pid/Manifest
index 63b3cf3227f4..66024affec62 100644
--- a/dev-python/pid/Manifest
+++ b/dev-python/pid/Manifest
@@ -1 +1,2 @@
DIST pid-2.1.1.tar.gz 9591 BLAKE2B 90bebcd225d96283c771b29d864ab35311e748978040e3667a13fa14d84e9f9f1bfe86a25c93bd4781c80938dc20cf14894f32de87a3c1cbef5797e168e71f0d SHA512 5f20338ca902d68a0c4a614b0b8229cd498712bf1750b68fa49037e9e6915c66ad562564d70d7c9308538f4302e90473a5d253dd6366bfa561f6a2248b21a45e
+DIST pid-2.2.0.tar.gz 10752 BLAKE2B 943626f9eccecb16f3da03d222cf44aae93179d4f97f922dca431960dbd744fb996239332b7e8557464aaf0797505645634ee3a23b88f0e98fb0a9d60f20e7c3 SHA512 bd35110fe67d916265985eeceed08d70a2e2e04507eaadf62bf6c67927fc6b36ca6eaf2a225947f5b0ad049e54eb2371c8576672c0ec3f819208cf6e11543fcc
diff --git a/dev-python/pid/pid-2.2.0.ebuild b/dev-python/pid/pid-2.2.0.ebuild
new file mode 100644
index 000000000000..9c1358e9687d
--- /dev/null
+++ b/dev-python/pid/pid-2.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pidfile featuring stale detection and file-locking"
+HOMEPAGE="https://pypi.python.org/pypi/pid https://github.com/trbs/pid/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="dev-python/nose[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests -v --with-coverage --cover-package=pid || die
+}