summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-30 08:00:08 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-30 08:09:59 +0100
commitcb360bc766b2ae6b0ceabbedd860d58766c9e826 (patch)
tree2506de368c691a22b13492e6271b87476d635a96
parentdev-python/Nuitka: Bump to 1.4.1 (diff)
downloadgentoo-cb360bc7.tar.gz
gentoo-cb360bc7.tar.bz2
gentoo-cb360bc7.zip
dev-python/flask-babel: Bump to 3.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/flask-babel/Manifest1
-rw-r--r--dev-python/flask-babel/flask-babel-3.0.1.ebuild41
-rw-r--r--dev-python/flask-babel/metadata.xml2
3 files changed, 43 insertions, 1 deletions
diff --git a/dev-python/flask-babel/Manifest b/dev-python/flask-babel/Manifest
index a8df930aabdf..0de8e3158deb 100644
--- a/dev-python/flask-babel/Manifest
+++ b/dev-python/flask-babel/Manifest
@@ -1,2 +1,3 @@
DIST Flask-Babel-2.0.0.tar.gz 19588 BLAKE2B dbd5d6f3af38fad15a4eb6d674222473d673a9002ced21ce09a913e0bce3285b1eac9a5a85ce53c1dcebf648444164f33a5c790039a7d01184d45c7734dac05f SHA512 2ad8f80b450db0cab7dd57f46158e7e653556d60869acdb3c2469d42dceca3fa97237cc960986655091c84a1a67a057d72ed510787ccb065d171e6f35764cb1d
DIST flask-babel-3.0.0.gh.tar.gz 20354 BLAKE2B feed1728f4083b1a421010e7ff8aa8b8362f8c9b54556e4d3268e4028b7a51a1364c8c5f13b07585af6e9382e903b66420797cf4c9bf29736870963120d0502a SHA512 a7f93047e82a0383aaa4114bcb626a9e08ed15e450c43e3a09198f75c02f501dfa6e2b8157c618cb8d19f94e76d93f8e826adc99bd146abeee85837d2618da86
+DIST flask-babel-3.0.1.gh.tar.gz 20367 BLAKE2B 760b3ff9b867ad14f138b75e3e13c9d40a9dd4fab1dcef57c062677d6e52b31340403125f13427b6f57487609794176055f888a277eacc2323281f6899f115d9 SHA512 d189aac67f5671c3053efa1c8049fc364c031a77568db7a502d63e2ea09867c981c12669752f1524faecaddd4594ab064249f08b8af50dfde7267322b50ed2af
diff --git a/dev-python/flask-babel/flask-babel-3.0.1.ebuild b/dev-python/flask-babel/flask-babel-3.0.1.ebuild
new file mode 100644
index 000000000000..c11b51e41219
--- /dev/null
+++ b/dev-python/flask-babel/flask-babel-3.0.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="i18n and l10n support for Flask based on Babel and pytz"
+HOMEPAGE="
+ https://python-babel.github.io/flask-babel/
+ https://github.com/python-babel/flask-babel/
+ https://pypi.org/project/flask-babel/
+"
+SRC_URI="
+ https://github.com/python-babel/flask-babel/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ <dev-python/Babel-3[${PYTHON_USEDEP}]
+ <dev-python/flask-3[${PYTHON_USEDEP}]
+ <dev-python/jinja-4[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/pallets-sphinx-themes
+distutils_enable_tests pytest
diff --git a/dev-python/flask-babel/metadata.xml b/dev-python/flask-babel/metadata.xml
index e75ac7bea354..4ca13ec297d6 100644
--- a/dev-python/flask-babel/metadata.xml
+++ b/dev-python/flask-babel/metadata.xml
@@ -7,7 +7,7 @@
</maintainer>
<stabilize-allarches/>
<upstream>
- <remote-id type="pypi">Flask-Babel</remote-id>
+ <remote-id type="pypi">flask-babel</remote-id>
<remote-id type="github">python-babel/flask-babel</remote-id>
<bugs-to>https://github.com/python-babel/flask-babel/issues</bugs-to>
</upstream>