summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2022-09-02 12:39:11 -0400
committerNick Sarnie <sarnex@gentoo.org>2022-09-02 12:42:28 -0400
commitcb47408a7db26f7d7ccdf308ca8e313d32dd7fe4 (patch)
tree9b60656f1a8d959c8c32413374789f1d2a762ba3
parentsci-libs/volk: add 2.5.1 (diff)
downloadgentoo-cb47408a.tar.gz
gentoo-cb47408a.tar.bz2
gentoo-cb47408a.zip
app-emulation/vendor-reset: add 0.1.1_pre20220902
Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
-rw-r--r--app-emulation/vendor-reset/Manifest1
-rw-r--r--app-emulation/vendor-reset/vendor-reset-0.1.1_pre20220902.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-emulation/vendor-reset/Manifest b/app-emulation/vendor-reset/Manifest
index 3d837e82ee92..17660f5bb12e 100644
--- a/app-emulation/vendor-reset/Manifest
+++ b/app-emulation/vendor-reset/Manifest
@@ -1 +1,2 @@
DIST vendor-reset-0.1.0.tar.gz 12718324 BLAKE2B 762ec8bc289b572ab8f8ecc3fa233e3c78c48c48a261c58ce1be9c10356a55957e0bd8fd01e3143443be74236bf9ed540b84d332788c67aa949599ccc5a564d3 SHA512 ed4dcb1a71fa8901732e729d37b501ac105cc2c93d0666e44c08e311d99a244027339d5709a9305ff992ca2acb2f337793cdb1f9369197911985cd20d6f3139f
+DIST vendor-reset-0.1.1_pre20220902.tar.gz 12724563 BLAKE2B 6d1aa45216a4a72981fc766ba7541873902272a27b5eebc08f7b2627f186d6236c3b6f576f997e35a3a9a3bb4b0c5f6a285585522e7c0eb86b446808e2de501b SHA512 27bc02fdbc7d0339c0f706e1ec8406bc47f163fca6d6471dd7ad92272a384ab7319f6180641177f90a38c11aee2def52ae408a2165438980b7fc3aea10f88b4e
diff --git a/app-emulation/vendor-reset/vendor-reset-0.1.1_pre20220902.ebuild b/app-emulation/vendor-reset/vendor-reset-0.1.1_pre20220902.ebuild
new file mode 100644
index 000000000000..d0f34c496d9c
--- /dev/null
+++ b/app-emulation/vendor-reset/vendor-reset-0.1.1_pre20220902.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/gnif/vendor-reset.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="7d43285a5054e4b2b18dbba771b57d365943a0f7"
+ SRC_URI="https://github.com/gnif/vendor-reset/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="Linux kernel vendor specific hardware reset module"
+HOMEPAGE="https://github.com/gnif/vendor-reset"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+pkg_setup() {
+ local CONFIG_CHECK="FTRACE KPROBES PCI_QUIRKS KALLSYMS FUNCTION_TRACER"
+ linux-mod_pkg_setup
+}
+
+src_compile() {
+ set_arch_to_kernel
+ default
+}
+
+src_install() {
+ set_arch_to_kernel
+ emake \
+ DESTDIR="${ED}" \
+ INSTALL_MOD_PATH="${ED}" \
+ install
+
+ insinto /etc/modules-load.d/
+ newins "${FILESDIR}"/modload.conf vendor-reset.conf
+}