summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-01-22 12:41:14 +0100
committerLouis Sautier <sbraz@gentoo.org>2020-01-22 12:48:23 +0100
commitcb5baf209a6731052c411d5c0cd0781fab4ca4f2 (patch)
treed7e6712ab40951f5bc3170e270de11da88afb552
parentx11-misc/rofi: Old (diff)
downloadgentoo-cb5baf209a6731052c411d5c0cd0781fab4ca4f2.tar.gz
gentoo-cb5baf209a6731052c411d5c0cd0781fab4ca4f2.tar.bz2
gentoo-cb5baf209a6731052c411d5c0cd0781fab4ca4f2.zip
dev-python/zipp: bump to 2.0.0, removes Py2 support+useless deps
Also bring back setuptools_scm dependency. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
-rw-r--r--dev-python/zipp/Manifest1
-rw-r--r--dev-python/zipp/zipp-2.0.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/zipp/Manifest b/dev-python/zipp/Manifest
index c7d6f037d763..80201e77d3eb 100644
--- a/dev-python/zipp/Manifest
+++ b/dev-python/zipp/Manifest
@@ -1,3 +1,4 @@
DIST zipp-0.5.2.tar.gz 10875 BLAKE2B 97e56b8e1cbff2344ee6b385085e6c821d61bd2c2510ac54e50a3f706515f1e22789168c97599787787b47f09dabe55abb594f5724d1d540f62d8d68fc32e36f SHA512 8c84b620844315ab1f1aa3c5bb29dcdf1271a0139198b5c3d6aa31ecb9a86f0dcef963819403d971ae0461c737312c064572c57ecf32d73dc973a5f69cf0375c
DIST zipp-0.6.0.tar.gz 10778 BLAKE2B 165ae85f51fe0c0232f6cf2dde70e2d7f8064413c15616d15e1ebd65cfe3c345bbd5b1b9713fa1171cad18015b605862509790bedd734edf5a7d8c80c5378af3 SHA512 18bef5aa3388ab3901bf08888127fc9cc17d8972a52f23ccf9a8035f09ee5598e17ddff833a10b81b2118461e0c517e88413518736763425a728cd0b19cc2052
DIST zipp-1.0.0.tar.gz 10821 BLAKE2B f5e0476cb0ca01054abc0c56f1a9581a6f537c002791c4a363238555ce9a211fe13114041374c1bfef426544545e3c654e5b0a7e0541c30b775757c43df6d756 SHA512 dbfadfedd30ca4cb31ac4163f367134d96e57405ef00d5f4c19c0af7a141f78487dec29a0ba94975584fcb462d22c8b536bf29c67b7e298368072e897b0e9d82
+DIST zipp-2.0.0.tar.gz 12813 BLAKE2B ace250658e72deae346484ea94762be9bd2a70705f40fa97e4dcb4ed419100c522f737f503878d69ae54a477045feeb0e028ffc7d636720a03c0825875851892 SHA512 5b53233036c9609e92029e103710100e1b18b3ad7d397128f8c910956ece96d0348a87f181196e69bb3e58e38be7fff9628705b68f56fe526129dbb143c8b8c8
diff --git a/dev-python/zipp/zipp-2.0.0.ebuild b/dev-python/zipp/zipp-2.0.0.ebuild
new file mode 100644
index 000000000000..55f92c6adc63
--- /dev/null
+++ b/dev-python/zipp/zipp-2.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+# [options.entry_points] is present in setup.cfg but it is empty
+DISTUTILS_USE_SETUPTOOLS=manual
+
+inherit distutils-r1
+
+DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE="https://github.com/jaraco/zipp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/more-itertools[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-3.4.2[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )
+"
+
+distutils_enable_sphinx docs \
+ ">=dev-python/jaraco-packaging-3.2" \
+ ">=dev-python/rst-linker-1.9"
+
+distutils_enable_tests pytest