summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-20 09:10:19 +0100
committerSam James <sam@gentoo.org>2024-05-20 09:10:52 +0100
commitcb65f4903f9b72a0ac51b6192762d659009baf4d (patch)
treedee19fb09ffabbef0b6c1309e02d1e7c294e8b42
parentdev-libs/mimalloc: conditionally add -latomic (diff)
downloadgentoo-cb65f4903f9b72a0ac51b6192762d659009baf4d.tar.gz
gentoo-cb65f4903f9b72a0ac51b6192762d659009baf4d.tar.bz2
gentoo-cb65f4903f9b72a0ac51b6192762d659009baf4d.zip
dev-libs/mimalloc: add 2.1.6
Includes a note to cleanup the libatomic hack in the next release. Bug: https://bugs.gentoo.org/923177 Bug: https://bugs.gentoo.org/931778 Closes: https://bugs.gentoo.org/930519 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/mimalloc/Manifest1
-rw-r--r--dev-libs/mimalloc/mimalloc-2.1.6.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/mimalloc/Manifest b/dev-libs/mimalloc/Manifest
index bd29ba52dd71..5e7df3a4597c 100644
--- a/dev-libs/mimalloc/Manifest
+++ b/dev-libs/mimalloc/Manifest
@@ -1,2 +1,3 @@
DIST mimalloc-2.1.2.tar.gz 1163868 BLAKE2B bba29671fdca81b682edeefe16a1239640ea28fee4e44c97d0422ae81e0b3e7141c733459ccafc6672780157af67ff7d2a10cf4157180e003b458332a79d8481 SHA512 927b046e67783b325a6e41e3a9a6d3d78306fa1c82255defd1f3a7a60a27fd809a601f65b1b27fa38f2064e124f29856d7c0e5ccc33c54c2e4b6ebb9816d74b1
DIST mimalloc-2.1.4.tar.gz 1133761 BLAKE2B 6271f54b8c0c0397bc0d7fb909009e05b9119c15ad3f926a82f078f3ffa7320503cc679487414d3b8e17bb41b17a43f71982727f80c7288b3b2d473992d706e5 SHA512 cdc43b212b9c67cd50b31bfae875387e3099165260fec995681a4079ca107c275452c2aadc5ee9a177391d1856750e0e2b104191bbb9829aeb5a42406267832e
+DIST mimalloc-2.1.6.tar.gz 1134456 BLAKE2B 1d4d0053e6c6b582d2c82f573b61dba7b3d1d6748999d313493d9db5bfb62e7379b48c72f88afab4e8b609971974488c9d42f96e2486d5905e2a9d78730d3231 SHA512 cbecca799be7a38b291c44ac765aa6ce36c6aeb0f064da942c568da38073350a122e7d1553e7929ee4f72f61ab3b767fa565f252cfd819463d2e1c73c25c5163
diff --git a/dev-libs/mimalloc/mimalloc-2.1.6.ebuild b/dev-libs/mimalloc/mimalloc-2.1.6.ebuild
new file mode 100644
index 000000000000..164388f44adf
--- /dev/null
+++ b/dev-libs/mimalloc/mimalloc-2.1.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib flag-o-matic
+
+DESCRIPTION="A compact general purpose allocator with excellent performance"
+HOMEPAGE="https://github.com/microsoft/mimalloc"
+SRC_URI="https://github.com/microsoft/mimalloc/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/2"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~sparc ~x86"
+IUSE="hardened test valgrind"
+RESTRICT="!test? ( test )"
+
+DEPEND="valgrind? ( dev-debug/valgrind )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DMI_SECURE=$(usex hardened)
+ -DMI_INSTALL_TOPLEVEL=ON
+ -DMI_BUILD_TESTS=$(usex test)
+ -DMI_BUILD_OBJECT=OFF
+ -DMI_BUILD_STATIC=OFF
+ -DMI_TRACK_VALGRIND=$(usex valgrind)
+ -DMI_LIBC_MUSL=$(usex elibc_musl)
+ )
+
+ # XXX: Should be able to clean this up after 2.1.6
+ # https://github.com/microsoft/mimalloc/pull/898
+ #
+ # Bug #923177, #931778: append -latomic if it is available
+ test-flags-CCLD "-latomic" &>/dev/null &&
+ mycmakeargs+=( -DMI_USE_LIBATOMIC=ON )
+
+ cmake-multilib_src_configure
+}