summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-05-10 22:21:18 -0400
committerAnthony G. Basile <blueness@gentoo.org>2019-05-10 22:21:45 -0400
commitcb76da37b02ed5bca29ca8f21be989f1dd5e80b6 (patch)
treefaebcf07688a59b4b12a5f9b6881cdc430e54820
parentapp-admin/ansible: 2.8.0-rc3 bump with cleanup (diff)
downloadgentoo-cb76da37.tar.gz
gentoo-cb76da37.tar.bz2
gentoo-cb76da37.zip
net-libs/libetpan: upstream patch to fix build on musl
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
-rw-r--r--net-libs/libetpan/files/libetpan-1.9.3-missing-stddev_h.patch30
-rw-r--r--net-libs/libetpan/libetpan-1.9.3.ebuild1
2 files changed, 31 insertions, 0 deletions
diff --git a/net-libs/libetpan/files/libetpan-1.9.3-missing-stddev_h.patch b/net-libs/libetpan/files/libetpan-1.9.3-missing-stddev_h.patch
new file mode 100644
index 000000000000..9d53f90190b0
--- /dev/null
+++ b/net-libs/libetpan/files/libetpan-1.9.3-missing-stddev_h.patch
@@ -0,0 +1,30 @@
+commit da9fd7839c9affea48f74a159a789fbb183b4be1
+Author: maxice8 <30738253+maxice8@users.noreply.github.com>
+Date: Fri Feb 1 01:58:08 2019 -0200
+
+ add missing stddef.h include for 'NULL' (#322)
+
+ clientid.c: In function 'mailimap_clientid':
+ clientid.c:66:38: error: 'NULL' undeclared (first use in this function)
+ if (mailimap_read_line(session) == NULL)
+ ^~~~
+ clientid.c:66:38: note: 'NULL' is defined in header '<stddef.h>'; did you forget to '#include <stddef.h>'?
+ clientid.c:39:1:
+ +#include <stddef.h>
+
+ clientid.c:66:38:
+ if (mailimap_read_line(session) == NULL)
+
+diff --git a/src/low-level/imap/clientid.c b/src/low-level/imap/clientid.c
+index 1c34637..38880dd 100644
+--- a/src/low-level/imap/clientid.c
++++ b/src/low-level/imap/clientid.c
+@@ -33,6 +33,8 @@
+ # include <config.h>
+ #endif
+
++#include <stdlib.h>
++
+ #include "mailimap_sender.h"
+ #include "clientid_sender.h"
+ #include "clientid.h"
diff --git a/net-libs/libetpan/libetpan-1.9.3.ebuild b/net-libs/libetpan/libetpan-1.9.3.ebuild
index b700e23e776a..262ae83217df 100644
--- a/net-libs/libetpan/libetpan-1.9.3.ebuild
+++ b/net-libs/libetpan/libetpan-1.9.3.ebuild
@@ -30,6 +30,7 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}"/${PN}-1.0-nonnull.patch
+ "${FILESDIR}"/${PN}-1.9.3-missing-stddev_h.patch
)
pkg_pretend() {