summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2021-10-11 07:34:10 +0200
committerSam James <sam@gentoo.org>2021-10-17 03:21:59 +0100
commitcb92c3517ba8f6192669b7b3583c80810d48c455 (patch)
treea7bec64130448e94b5c11741fafab369e930c0f4
parentapp-antivirus/clamav: use subslot operator on ncurses (diff)
downloadgentoo-cb92c351.tar.gz
gentoo-cb92c351.tar.bz2
gentoo-cb92c351.zip
dev-libs/imath: bump to 3.1.3
New cmake option to build docs using doxygen / sphinx Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/imath/Manifest1
-rw-r--r--dev-libs/imath/imath-3.1.3.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-libs/imath/Manifest b/dev-libs/imath/Manifest
index 5190cfb234c7..84c2392f3c31 100644
--- a/dev-libs/imath/Manifest
+++ b/dev-libs/imath/Manifest
@@ -1,2 +1,3 @@
DIST imath-3.0.5.tar.gz 528503 BLAKE2B c1fcb199a81aff25f1ad26ccfcef2802861401f3fee5dc24035216aa16fd9a5344ec6c37139a0850f1a4bc580dc1fdd068eca9473a19e4aaf329cfc5f53a4cd6 SHA512 df206315d822266cf32a5a4399abff7ad1dd0bd1f0372d61f61516e2acdefd13e3cfd9cf54373a3fb49bb28c9f80915ca5ecaec2a068a1d6ea231d71a5316da2
DIST imath-3.1.1.tar.gz 568231 BLAKE2B a1210b5f6ff4723a133d317c2b40338e387973a1409868a218192a53778b86a0912c77911bdf76286a6ed6931175aec38bf24ddc0c76eed3375b7a2945dba124 SHA512 b2f4cc21e44094ef139a1f04bb997c7e41770ff886457fff00d65ca477ba579c86fd5fbd465998c4519855fcb34328ac834d84d0d011f758f56a20ef79e9ca3d
+DIST imath-3.1.3.tar.gz 570840 BLAKE2B b037c9bdee87f58c7a2be9dbda52c89c26eba25fe07342710578f9eef4b90a49b9d5dc5451702c960ae94427d7f748b79b81b7fc9ad350d2252e9e4bf6a1d6cc SHA512 a11f5e736bc49098d735c7903f186c15b03efbec082a8cf2e6635546368035cec0d36c7ae64bfd01bd8eeffb2dd247b8dab19e440a3e1fe33008edacc1268f75
diff --git a/dev-libs/imath/imath-3.1.3.ebuild b/dev-libs/imath/imath-3.1.3.ebuild
new file mode 100644
index 000000000000..8ce94a93b3bc
--- /dev/null
+++ b/dev-libs/imath/imath-3.1.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit cmake python-single-r1
+
+MY_PN="${PN^}"
+
+DESCRIPTION="Imath basic math package"
+HOMEPAGE="https://imath.readthedocs.io"
+SRC_URI="https://github.com/AcademySoftwareFoundation/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+# re-keywording needed for (according to ilmbase keywords): ~x64-macos ~x86-solaris
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="BSD"
+SLOT="3/29"
+IUSE="doc large-stack python static-libs test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+# blocker due to file collision #803347
+RDEPEND="
+ !dev-libs/imath:0
+ sys-libs/zlib
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-libs/boost:=[python,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ ')
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( $(python_gen_cond_dep 'dev-python/breathe[${PYTHON_USEDEP}]') )
+ python? ( ${PYTHON_DEPS} )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.1.1-0001-changes-needed-for-proper-slotting.patch )
+DOCS=( CHANGES.md CONTRIBUTORS.md README.md SECURITY.md docs/PortingGuide2-3.md )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local majorver=$(ver_cut 1)
+
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=$(usex !static-libs)
+ -DDOCS=$(usex doc)
+ -DIMATH_ENABLE_LARGE_STACK=$(usex large-stack)
+ -DIMATH_HALF_USE_LOOKUP_TABLE=ON
+ -DIMATH_INSTALL_PKG_CONFIG=ON
+ -DIMATH_OUTPUT_SUBDIR="${MY_PN}-${majorver}"
+ -DIMATH_USE_CLANG_TIDY=OFF
+ -DIMATH_USE_NOEXCEPT=ON
+ )
+ if use python; then
+ mycmakeargs+=(
+ # temp. disable for finding libboost_python310, #803032
+# -DBoost_NO_BOOST_CMAKE=OFF
+ -DPYTHON=ON
+ -DPython3_EXECUTABLE="${PYTHON}"
+ -DPython3_INCLUDE_DIR=$(python_get_includedir)
+ -DPython3_LIBRARY=$(python_get_library_path)
+ )
+ fi
+
+ cmake_src_configure
+}