summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-04-20 14:10:47 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-04-20 15:19:24 +0200
commitcb9a47049be9fe1036707646efd976333f73b9a2 (patch)
treece07572ad7e1cba6688dd407c19ba690dff4b96d
parentapp-portage/portpeek: Recognize USE_EXPAND in package.use. See bug #615998. T... (diff)
downloadgentoo-cb9a4704.tar.gz
gentoo-cb9a4704.tar.bz2
gentoo-cb9a4704.zip
kde-frameworks/knotifications: Fix USE=dbus build switch
Reported-by: aayla.secura.1138@gmail.com Gentoo-bug: 616072 Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--kde-frameworks/knotifications/knotifications-5.33.0-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/kde-frameworks/knotifications/knotifications-5.33.0-r1.ebuild b/kde-frameworks/knotifications/knotifications-5.33.0-r1.ebuild
new file mode 100644
index 000000000000..4eb54a810f3f
--- /dev/null
+++ b/kde-frameworks/knotifications/knotifications-5.33.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="false"
+inherit kde5
+
+DESCRIPTION="Framework for notifying the user of an event"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="dbus nls speech X"
+
+# drop qtgui subslot operator when QT_MINIMAL >= 5.7.0
+RDEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui '' '' '5=')
+ $(add_qt_dep qtwidgets)
+ media-libs/phonon[qt5]
+ dbus? ( dev-libs/libdbusmenu-qt[qt5] )
+ speech? ( $(add_qt_dep qtspeech) )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libX11
+ x11-libs/libXtst
+ )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+ X? ( x11-proto/xproto )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package dbus dbusmenu-qt5)
+ $(cmake-utils_use_find_package speech Qt5TextToSpeech)
+ $(cmake-utils_use_find_package X X11)
+ )
+
+ kde5_src_configure
+}