summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2021-05-24 00:47:11 -0700
committerZac Medico <zmedico@gentoo.org>2021-05-24 02:05:08 -0700
commitcba21902d9a8d1ac07d2ff5b0d932e71fc1fac67 (patch)
tree7090745903f8ae09c3a5de3dd07c58689ea8d26a
parentsci-visualization/scidavis: fix dep on .../lupdate (diff)
downloadgentoo-cba21902d9a8d1ac07d2ff5b0d932e71fc1fac67.tar.gz
gentoo-cba21902d9a8d1ac07d2ff5b0d932e71fc1fac67.tar.bz2
gentoo-cba21902d9a8d1ac07d2ff5b0d932e71fc1fac67.zip
sys-apps/portage: Bump to version 3.0.19
#520378: allow emerge --fetchonly to log to emerge-fetch.log #698244: portage(5) document user patch / eapply_user #781854: Suggest PORTAGE_LOG_FILTER_FILE_CMD cat fallback #782724: sort emerge --unmerge order for determinism #783957: lazily evaluate cnf_* variables in tests #784566: make emerge insensitive to relative order of optional and positional arguments #787545: emerge CTRL C may be ignored when running pkg_pretend #787563: ebuild-ipc could handle KeyboardInterrupt #788967: emerge --jobs= triggers TypeError Bug: https://bugs.gentoo.org/785484 Bug: https://bugs.gentoo.org/788967 Bug: https://bugs.gentoo.org/787563 Bug: https://bugs.gentoo.org/787545 Bug: https://bugs.gentoo.org/784566 Bug: https://bugs.gentoo.org/783957 Bug: https://bugs.gentoo.org/782724 Bug: https://bugs.gentoo.org/781854 Bug: https://bugs.gentoo.org/698244 Bug: https://bugs.gentoo.org/520378 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--sys-apps/portage/Manifest1
-rw-r--r--sys-apps/portage/portage-3.0.19.ebuild266
2 files changed, 267 insertions, 0 deletions
diff --git a/sys-apps/portage/Manifest b/sys-apps/portage/Manifest
index f28a04d415ad..ce22a29bfeea 100644
--- a/sys-apps/portage/Manifest
+++ b/sys-apps/portage/Manifest
@@ -3,3 +3,4 @@ DIST portage-3.0.17-bug-775053-setup-globals-double-prefix-ff7d78.patch 908 BLAK
DIST portage-3.0.17-bug-775239-_test_lock_fn-tempfile-leak-d8a12c.patch 733 BLAKE2B 8281107d270908b49218603ef64b7580c5d6e0bf015eabef4c35f8ee9d76b2b7790f4b75404b9d85fd030c3a0f9183e88894d67bf547978f3fa0bed0630112cf SHA512 5ea4ccc7d517ea79a02fad77d20502d613cedf9df00edebf73972979bd5a469f47c14ae5b69b850f0ce9860b9fdf1b5bb283e138bd7be5b832928697e4bba42b
DIST portage-3.0.17.tar.xz 970076 BLAKE2B 261d8d3b0da5bb77f37328219365a59d7ac56a22e887de59a6b702fcf895493f7a0aac1af744bc67b80c9e2aa730795e507764e9e1c807c247d1ccbe6f825d2f SHA512 6f4a50b005a67e6eea24600d10179fd48b4aa1de4cdf99bc310854dc303248408f8a31bca4135e4e530fcbd2b3d99c2f89644e4e4240e3a754fd97e949403ffc
DIST portage-3.0.18.tar.xz 971692 BLAKE2B 0a8d2062fce1bf85a2f1025d17ddd3eafc987fd93c01f17bcc4487b23841e530451502417e24bbe58175b4fee871ceb528696775116a60f93b7b841d14ecf7a3 SHA512 d3f4b5258748fbef7b8ec000685b7e42804123a5c6b474bb6679666c2696a16e3bd202108df6e647770406539ff223bfd0deb1a3b4240e0a7ba1f2ec52aca2cd
+DIST portage-3.0.19.tar.gz 1347687 BLAKE2B 86eea08c2559b2d5a3eac39d8f7523380769710e7b4e3973463410bc291e746d9a36708e26d9b6456c06f67157fd04385c98ae28e25e48dba510fbaaab2d3536 SHA512 355153839219b93ae5d7c844ac5ed7ada10b2932d4a8e2b8208793fc33dfba3d46abe5ec7ecfbef9f16f23a6b21e57b7b14247f0b1fd85018a07e198bafa209c
diff --git a/sys-apps/portage/portage-3.0.19.ebuild b/sys-apps/portage/portage-3.0.19.ebuild
new file mode 100644
index 000000000000..e6511cf77da8
--- /dev/null
+++ b/sys-apps/portage/portage-3.0.19.ebuild
@@ -0,0 +1,266 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+PYTHON_REQ_USE='bzip2(+),threads(+)'
+TMPFILES_OPTIONAL=1
+
+inherit distutils-r1 linux-info tmpfiles prefix
+
+DESCRIPTION="Portage is the package management and distribution system for Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+IUSE="apidoc build doc gentoo-dev +ipc +native-extensions +rsync-verify selinux test xattr"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ app-arch/xz-utils
+ test? ( dev-vcs/git )"
+DEPEND="!build? ( $(python_gen_impl_dep 'ssl(+)') )
+ >=app-arch/tar-1.27
+ dev-lang/python-exec:2
+ >=sys-apps/sed-4.0.5 sys-devel/patch
+ doc? ( app-text/xmlto ~app-text/docbook-xml-dtd-4.4 )
+ apidoc? (
+ dev-python/sphinx
+ dev-python/sphinx-epytext
+ )"
+# Require sandbox-2.2 for bug #288863.
+# For whirlpool hash, require python[ssl] (bug #425046).
+# For compgen, require bash[readline] (bug #445576).
+# app-portage/gemato goes without PYTHON_USEDEP since we're calling
+# the executable.
+RDEPEND="
+ acct-user/portage
+ app-arch/zstd
+ >=app-arch/tar-1.27
+ dev-lang/python-exec:2
+ >=sys-apps/findutils-4.4
+ !build? (
+ >=sys-apps/sed-4.0.5
+ app-shells/bash:0[readline]
+ >=app-admin/eselect-1.2
+ rsync-verify? (
+ >=app-portage/gemato-14.5[${PYTHON_USEDEP}]
+ >=app-crypt/openpgp-keys-gentoo-release-20180706
+ >=app-crypt/gnupg-2.2.4-r2[ssl(-)]
+ )
+ )
+ elibc_glibc? ( >=sys-apps/sandbox-2.2 )
+ elibc_musl? ( >=sys-apps/sandbox-2.2 )
+ elibc_uclibc? ( >=sys-apps/sandbox-2.2 )
+ kernel_linux? ( sys-apps/util-linux )
+ >=app-misc/pax-utils-0.1.17
+ selinux? ( >=sys-libs/libselinux-2.0.94[python,${PYTHON_USEDEP}] )
+ xattr? ( kernel_linux? (
+ >=sys-apps/install-xattr-0.3
+ ) )
+ !<app-admin/logrotate-3.8.0
+ !<app-portage/gentoolkit-0.4.6
+ !<app-portage/repoman-2.3.10
+ !~app-portage/repoman-3.0.0"
+PDEPEND="
+ !build? (
+ >=net-misc/rsync-2.6.4
+ userland_GNU? ( >=sys-apps/coreutils-6.4 )
+ )"
+# coreutils-6.4 rdep is for date format in emerge-webrsync #164532
+# NOTE: FEATURES=installsources requires debugedit and rsync
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+pkg_pretend() {
+ local CONFIG_CHECK="~IPC_NS ~PID_NS ~NET_NS ~UTS_NS"
+
+ check_extra_config
+}
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ sed -e "s:^VERSION = \"HEAD\"$:VERSION = \"${PV}\":" -i lib/portage/__init__.py || die
+
+ if use gentoo-dev; then
+ einfo "Disabling --dynamic-deps by default for gentoo-dev..."
+ sed -e 's:\("--dynamic-deps", \)\("y"\):\1"n":' \
+ -i lib/_emerge/create_depgraph_params.py || \
+ die "failed to patch create_depgraph_params.py"
+
+ einfo "Enabling additional FEATURES for gentoo-dev..."
+ echo 'FEATURES="${FEATURES} strict-keepdir"' \
+ >> cnf/make.globals || die
+ fi
+
+ if use native-extensions; then
+ printf "[build_ext]\nportage-ext-modules=true\n" >> \
+ setup.cfg || die
+ fi
+
+ if ! use ipc ; then
+ einfo "Disabling ipc..."
+ sed -e "s:_enable_ipc_daemon = True:_enable_ipc_daemon = False:" \
+ -i lib/_emerge/AbstractEbuildProcess.py || \
+ die "failed to patch AbstractEbuildProcess.py"
+ fi
+
+ if use xattr && use kernel_linux ; then
+ einfo "Adding FEATURES=xattr to make.globals ..."
+ echo -e '\nFEATURES="${FEATURES} xattr"' >> cnf/make.globals \
+ || die "failed to append to make.globals"
+ fi
+
+ if use build || ! use rsync-verify; then
+ sed -e '/^sync-rsync-verify-metamanifest/s|yes|no|' \
+ -e '/^sync-webrsync-verify-signature/s|yes|no|' \
+ -i cnf/repos.conf || die "sed failed"
+ fi
+
+ if [[ -n ${EPREFIX} ]] ; then
+ einfo "Setting portage.const.EPREFIX ..."
+ hprefixify -e "s|^(EPREFIX[[:space:]]*=[[:space:]]*\").*|\1${EPREFIX}\"|" \
+ -w "/_BINARY/" lib/portage/const.py
+
+ einfo "Prefixing shebangs ..."
+ > "${T}/shebangs" || die
+ while read -r -d $'\0' ; do
+ local shebang=$(head -n1 "$REPLY")
+ if [[ ${shebang} == "#!"* && ! ${shebang} == "#!${EPREFIX}/"* ]] ; then
+ echo "${REPLY}" >> "${T}/shebangs" || die
+ fi
+ done < <(find . -type f -executable ! -name etc-update -print0)
+
+ if [[ -s ${T}/shebangs ]]; then
+ xargs sed -i -e "1s:^#!:#!${EPREFIX}:" < "${T}/shebangs" || die "sed failed"
+ fi
+
+ einfo "Adjusting make.globals, repos.conf and etc-update ..."
+ hprefixify cnf/{make.globals,repos.conf} bin/etc-update
+
+ if use prefix-guest ; then
+ sed -e "s|^\(main-repo = \).*|\\1gentoo_prefix|" \
+ -e "s|^\\[gentoo\\]|[gentoo_prefix]|" \
+ -e "s|^\(sync-uri = \).*|\\1rsync://rsync.prefix.bitzolder.nl/gentoo-portage-prefix|" \
+ -i cnf/repos.conf || die "sed failed"
+ fi
+
+ einfo "Adding FEATURES=force-prefix to make.globals ..."
+ echo -e '\nFEATURES="${FEATURES} force-prefix"' >> cnf/make.globals \
+ || die "failed to append to make.globals"
+ fi
+
+ cd "${S}/cnf" || die
+ if [ -f "make.conf.example.${ARCH}".diff ]; then
+ patch make.conf.example "make.conf.example.${ARCH}".diff || \
+ die "Failed to patch make.conf.example"
+ else
+ eerror ""
+ eerror "Portage does not have an arch-specific configuration for this arch."
+ eerror "Please notify the arch maintainer about this issue. Using generic."
+ eerror ""
+ fi
+}
+
+python_compile_all() {
+ local targets=()
+ use doc && targets+=( docbook )
+ use apidoc && targets+=( apidoc )
+
+ if [[ ${targets[@]} ]]; then
+ esetup.py "${targets[@]}"
+ fi
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install() {
+ # Install sbin scripts to bindir for python-exec linking
+ # they will be relocated in pkg_preinst()
+ distutils-r1_python_install \
+ --system-prefix="${EPREFIX}/usr" \
+ --bindir="$(python_get_scriptdir)" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ --portage-bindir="${EPREFIX}/usr/lib/portage/${EPYTHON}" \
+ --sbindir="$(python_get_scriptdir)" \
+ --sysconfdir="${EPREFIX}/etc" \
+ "${@}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ local targets=()
+ use doc && targets+=(
+ install_docbook
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ )
+ use apidoc && targets+=(
+ install_apidoc
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ )
+
+ # install docs
+ if [[ ${targets[@]} ]]; then
+ esetup.py "${targets[@]}"
+ fi
+
+ dotmpfiles "${FILESDIR}"/portage-ccache.conf
+
+ # Due to distutils/python-exec limitations
+ # these must be installed to /usr/bin.
+ local sbin_relocations='archive-conf dispatch-conf emaint env-update etc-update fixpackages regenworld'
+ einfo "Moving admin scripts to the correct directory"
+ dodir /usr/sbin
+ for target in ${sbin_relocations}; do
+ einfo "Moving /usr/bin/${target} to /usr/sbin/${target}"
+ mv "${ED}/usr/bin/${target}" "${ED}/usr/sbin/${target}" || die "sbin scripts move failed!"
+ done
+}
+
+pkg_preinst() {
+ python_setup
+ local sitedir=$(python_get_sitedir)
+ [[ -d ${D}${sitedir} ]] || die "${D}${sitedir}: No such directory"
+ env -u DISTDIR \
+ -u PORTAGE_OVERRIDE_EPREFIX \
+ -u PORTAGE_REPOSITORIES \
+ -u PORTDIR \
+ -u PORTDIR_OVERLAY \
+ PYTHONPATH="${D}${sitedir}${PYTHONPATH:+:${PYTHONPATH}}" \
+ "${PYTHON}" -m portage._compat_upgrade.default_locations || die
+
+ env -u BINPKG_COMPRESS -u PORTAGE_REPOSITORIES \
+ PYTHONPATH="${D}${sitedir}${PYTHONPATH:+:${PYTHONPATH}}" \
+ "${PYTHON}" -m portage._compat_upgrade.binpkg_compression || die
+
+ env -u FEATURES -u PORTAGE_REPOSITORIES \
+ PYTHONPATH="${D}${sitedir}${PYTHONPATH:+:${PYTHONPATH}}" \
+ "${PYTHON}" -m portage._compat_upgrade.binpkg_multi_instance || die
+
+ # elog dir must exist to avoid logrotate error for bug #415911.
+ # This code runs in preinst in order to bypass the mapping of
+ # portage:portage to root:root which happens after src_install.
+ keepdir /var/log/portage/elog
+ # This is allowed to fail if the user/group are invalid for prefix users.
+ if chown portage:portage "${ED}"/var/log/portage{,/elog} 2>/dev/null ; then
+ chmod g+s,ug+rwx "${ED}"/var/log/portage{,/elog}
+ fi
+
+ if has_version "<${CATEGORY}/${PN}-2.3.77"; then
+ elog "The emerge --autounmask option is now disabled by default, except for"
+ elog "portions of behavior which are controlled by the --autounmask-use and"
+ elog "--autounmask-license options. For backward compatibility, previous"
+ elog "behavior of --autounmask=y and --autounmask=n is entirely preserved."
+ elog "Users can get the old behavior simply by adding --autounmask to the"
+ elog "make.conf EMERGE_DEFAULT_OPTS variable. For the rationale for this"
+ elog "change, see https://bugs.gentoo.org/658648."
+ fi
+}