summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-28 06:36:01 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-28 07:31:45 +0200
commitcbacc34ce93fbb81e91c20f4e8960130bfbe105c (patch)
treeb3040731b6138447ab85e5b0d627e44b7d46567c
parentdev-python/boto3: Bump to 1.18.8 (diff)
downloadgentoo-cbacc34c.tar.gz
gentoo-cbacc34c.tar.bz2
gentoo-cbacc34c.zip
app-admin/awscli: Bump to 1.20.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.20.8.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 0b396b73de37..6a8ea305894e 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -8,3 +8,4 @@ DIST awscli-1.20.4.tar.gz 2043470 BLAKE2B 58722fe4277a7950665913e8b9ae99de8017cf
DIST awscli-1.20.5.tar.gz 2043880 BLAKE2B f4b833baf883479ed63e09de998b41e0e0e88006d4779b0be86396bafdb559cd8b158f30f012045f699b7c374a2e6584534534fd778ac7669016d23b06534080 SHA512 598163c27dce2ee166fd1d27cbca62c14c807118df99951963665a064fb71ba795726ef3ea46cc51bd2a51f256364c66edb88d1cdd8f319b2025c0cecfe9f6ca
DIST awscli-1.20.6.tar.gz 2044686 BLAKE2B 6513afc020855a103c5a4ee2b2aa6fc7355f2ebc445d3a89403045a8111a6beef7b934640de020a43fdd670fd4efb2f02dc907826b6a8f3335f6119267dfba10 SHA512 f53a56ae1aed266a4c6bd9236b15a070feaca804ea5276dbe0ad01e006866a17f2ab965ff086640cf62e002da0033c9091c56de1eb4b89a25cbeed329fd63e08
DIST awscli-1.20.7.tar.gz 2045304 BLAKE2B d8f086d8d2eb36645e77fa3d9ae7c196ed3a3fddcc2a0218696f92bd69e10b453be1340b965a8d8e6697bbd3c45013d72de3ed0d31b5823515a5a0092a812858 SHA512 a41bd3ebc34a65add66ef95d5194ba07907a08f7368b0fcd6551af2070c46c4a509af47d30aeadabddce19d1a61200a58faf40a7e2f759e64915cfb2826666ab
+DIST awscli-1.20.8.tar.gz 2046203 BLAKE2B 12fb4b26f030667f43778fc713fc83becb2bb78b9f5b7b9de1faae1b74207e27487bc4731e234767b11ce152cfbfb5b41fcf66e4d4793b0a754a7634219d455a SHA512 11861a471a3d43305dbc2d18b50848849736c6e55a0ed6ae0d7bafe73389a6011100b6b0ccbec243ea2f2846e8e689412d04a68bcf8324027a03f31062807dec
diff --git a/app-admin/awscli/awscli-1.20.8.ebuild b/app-admin/awscli/awscli-1.20.8.ebuild
new file mode 100644
index 000000000000..ff429f8d3a3e
--- /dev/null
+++ b/app-admin/awscli/awscli-1.20.8.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install nose
+
+PATCHES=(
+ "${FILESDIR}"/awscli-1.19.47-py39.patch
+)
+
+python_test() {
+ distutils_install_for_testing
+ # integration tests require AWS credentials and Internet access
+ nosetests -v tests/{functional,unit} ||
+ die "Tests failed for ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}