summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-07-11 17:17:12 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-07-24 18:51:43 +0200
commitcbae8092d98f132686474f6f74b2a03094f4dfc6 (patch)
tree1ef0411632890facd108a71438b3a8e650499444
parentdev-java/commons-collections: add missing Automatic-Module-Name (diff)
downloadgentoo-cbae8092d98f132686474f6f74b2a03094f4dfc6.tar.gz
gentoo-cbae8092d98f132686474f6f74b2a03094f4dfc6.tar.bz2
gentoo-cbae8092d98f132686474f6f74b2a03094f4dfc6.zip
dev-java/commons-io: add missing Automatic-Module-Name
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--dev-java/commons-io/commons-io-2.11.0-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-java/commons-io/commons-io-2.11.0-r1.ebuild b/dev-java/commons-io/commons-io-2.11.0-r1.ebuild
new file mode 100644
index 000000000000..73150451cd28
--- /dev/null
+++ b/dev-java/commons-io/commons-io-2.11.0-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://mirror.dkm.cz/apache//commons/io/source/commons-io-2.11.0-src.tar.gz --slot 0 --keywords "~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris" --ebuild commons-io-2.11.0.ebuild
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="commons-io:commons-io:2.11.0"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Utility classes, stream implementations, file filters, and much more"
+HOMEPAGE="https://commons.apache.org/proper/commons-io/"
+SRC_URI="mirror://apache/commons/io/source/${P}-src.tar.gz -> ${P}-sources.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+
+# Compile dependencies
+# POM: pom.xml
+# test? com.google.jimfs:jimfs:1.2 -> !!!groupId-not-found!!!
+# test? org.apache.commons:commons-lang3:3.12.0 -> >=dev-java/commons-lang-3.12.0:3.6
+# test? org.junit-pioneer:junit-pioneer:1.4.2 -> !!!groupId-not-found!!!
+# test? org.junit.jupiter:junit-jupiter:5.7.2 -> !!!groupId-not-found!!!
+# test? org.mockito:mockito-inline:3.11.2 -> !!!artifactId-not-found!!!
+# test? org.openjdk.jmh:jmh-core:1.32 -> !!!groupId-not-found!!!
+# test? org.openjdk.jmh:jmh-generator-annprocess:1.32 -> !!!groupId-not-found!!!
+
+DEPEND="
+ >=virtual/jdk-1.8:*
+ test? (
+ >=dev-java/commons-lang-3.12.0:3.6
+ )
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+"
+
+# some test dependencies are missing
+RESTRICT="test"
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_ENCODING="iso-8859-1"
+
+JAVA_SRC_DIR="src/main/java"
+
+JAVA_TEST_GENTOO_CLASSPATH="commons-lang-3.6"
+JAVA_TEST_SRC_DIR="src/test/java"
+JAVA_TEST_RESOURCE_DIRS="src/test/resources"
+JAVA_AUTOMATIC_MODULE_NAME="org.apache.commons.io"