summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-05-10 22:35:28 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2016-05-11 09:48:03 +0100
commitcbde8a27af63e696295d4654ea34487b9c4fce04 (patch)
tree223c1a8efab7edda69e0d6da3eff556d4b463fd4
parentdev-haskell/fgl-arbitrary: new package, a depend of graphviz (diff)
downloadgentoo-cbde8a27af63e696295d4654ea34487b9c4fce04.tar.gz
gentoo-cbde8a27af63e696295d4654ea34487b9c4fce04.tar.bz2
gentoo-cbde8a27af63e696295d4654ea34487b9c4fce04.zip
dev-haskell/graphviz: new package, a depend of darcs-2.12.0
Package-Manager: portage-2.2.28
-rw-r--r--dev-haskell/graphviz/Manifest1
-rw-r--r--dev-haskell/graphviz/graphviz-2999.18.0.2-r1.ebuild48
-rw-r--r--dev-haskell/graphviz/metadata.xml35
3 files changed, 84 insertions, 0 deletions
diff --git a/dev-haskell/graphviz/Manifest b/dev-haskell/graphviz/Manifest
new file mode 100644
index 000000000000..6b4b60c338fe
--- /dev/null
+++ b/dev-haskell/graphviz/Manifest
@@ -0,0 +1 @@
+DIST graphviz-2999.18.0.2.tar.gz 223908 SHA256 0ce1dca248e549b005798472cc6b906143369d987cf482fc0435b1029e5cc567 SHA512 8b27a81af2d31780801534f785bfda1dfbd127e176fa2c4bada2b33a7c80166fbb0efa67706296201bb19d201b8e2ac56453be0d8fcb488b93feb95d2acd8a09 WHIRLPOOL d88550711ea99c586d6a272c3a99c12ccf91cf096e80585d6f61c71bbb3dc6842e9876632823ca096325a97253a62ab16f85a7f7055cb8593ed8b87d206c08ec
diff --git a/dev-haskell/graphviz/graphviz-2999.18.0.2-r1.ebuild b/dev-haskell/graphviz/graphviz-2999.18.0.2-r1.ebuild
new file mode 100644
index 000000000000..f58fc6625b83
--- /dev/null
+++ b/dev-haskell/graphviz/graphviz-2999.18.0.2-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+#hackport: flags: -test-parsing
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Bindings to Graphviz for graph visualisation"
+HOMEPAGE="http://projects.haskell.org/graphviz/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # too slow
+
+RDEPEND=">=dev-haskell/colour-2.3:=[profile?] <dev-haskell/colour-2.4:=[profile?]
+ >=dev-haskell/dlist-0.5:=[profile?] <dev-haskell/dlist-0.8:=[profile?]
+ >=dev-haskell/fgl-5.4:=[profile?] <dev-haskell/fgl-5.6:=[profile?]
+ >=dev-haskell/polyparse-1.9:=[profile?]
+ >=dev-haskell/temporary-1.1:=[profile?] <dev-haskell/temporary-1.3:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
+ >=dev-haskell/wl-pprint-text-1.1.0.0:=[profile?] <dev-haskell/wl-pprint-text-1.2.0.0:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.14
+ test? ( >=dev-haskell/fgl-arbitrary-0.2 <dev-haskell/fgl-arbitrary-0.3
+ >=dev-haskell/quickcheck-2.3 <dev-haskell/quickcheck-2.9 )
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'polyparse >=1.9 && <1.12' 'polyparse >=1.9'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-test-parsing
+}
diff --git a/dev-haskell/graphviz/metadata.xml b/dev-haskell/graphviz/metadata.xml
new file mode 100644
index 000000000000..01b1d2a5ff68
--- /dev/null
+++ b/dev-haskell/graphviz/metadata.xml
@@ -0,0 +1,35 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This library provides bindings for the Dot language used by the
+ Graphviz (&lt;http://graphviz.org/&gt;) suite of programs for visualising
+ graphs, as well as functions to call those programs.
+
+ Main features of the graphviz library include:
+
+ * Almost complete coverage of all Graphviz attributes and syntax.
+
+ * Support for specifying clusters.
+
+ * The ability to use a custom node type.
+
+ * Functions for running a Graphviz layout tool with all specified
+ output types.
+
+ * The ability to not only generate but also parse Dot code with two
+ options: strict and liberal (in terms of ordering of statements).
+
+ * Functions to convert FGL graphs and other graph-like data structures
+ to Dot code - including support to group them into clusters - with a
+ high degree of customisation by specifying which attributes to use
+ and limited support for the inverse operation.
+
+ * Round-trip support for passing an FGL graph through Graphviz to
+ augment node and edge labels with positional information, etc.
+ </longdescription>
+</pkgmetadata>