summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOskari Pirhonen <xxc3ncoredxx@gmail.com>2023-11-06 22:37:17 -0600
committerYixun Lan <dlan@gentoo.org>2023-11-11 12:26:26 +0000
commitcc06acf6af6966565992c137bc843bcff54da812 (patch)
tree153f0bc85a6539c4e41685f2e8a6f3ca1bea59e8
parentmedia-sound/qtractor: bump to 0.9.36 (diff)
downloadgentoo-cc06acf6.tar.gz
gentoo-cc06acf6.tar.bz2
gentoo-cc06acf6.zip
app-text/wgetpaste: add -q/--quiet
Closes: https://github.com/gentoo/gentoo/pull/33702 Signed-off-by: Oskari Pirhonen <xxc3ncoredxx@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--app-text/wgetpaste/files/wgetpaste-2.33-added-quiet-flag.patch61
-rw-r--r--app-text/wgetpaste/wgetpaste-2.33-r4.ebuild (renamed from app-text/wgetpaste/wgetpaste-2.33-r3.ebuild)1
2 files changed, 62 insertions, 0 deletions
diff --git a/app-text/wgetpaste/files/wgetpaste-2.33-added-quiet-flag.patch b/app-text/wgetpaste/files/wgetpaste-2.33-added-quiet-flag.patch
new file mode 100644
index 000000000000..f8bac315d2f2
--- /dev/null
+++ b/app-text/wgetpaste/files/wgetpaste-2.33-added-quiet-flag.patch
@@ -0,0 +1,61 @@
+From 75e68f79adaae7f50920e84a748b7ebb4a3a8a1d Mon Sep 17 00:00:00 2001
+From: Richard-Rogalski <rrogalski@tutanota.com>
+Date: Mon, 6 Nov 2023 14:00:02 -0600
+Subject: [PATCH] Added --quiet flag
+
+Signed-off-by: Richard Rogalski <rrogalski@firemail.cc>
+Closes: #19
+---
+See also: https://github.com/zlin/wgetpaste/pull/51
+- Oskari
+
+ _wgetpaste | 1 +
+ wgetpaste | 6 +++++-
+ 2 files changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/_wgetpaste b/_wgetpaste
+index c4703e5..63696ad 100644
+--- a/_wgetpaste
++++ b/_wgetpaste
+@@ -50,6 +50,7 @@ _arguments -s : \
+ '(--xclippaste -C)'{--xclippaste,-C}'[write resulting url to the X clipboard selection buffer]' \
+ '(--raw -r)'{--raw,-r}'[show url for the raw paste]' \
+ '(--tee -t)'{--tee,-t}'[use tee to show what is being pasted]' \
++ '(--quiet -q)'{--quiet,-q}'[show the url only]' \
+ '(--verbose -v)'{--verbose,-v}'[show wget stderr output if no url is received]' \
+ '--debug[be very verbose]' \
+ '(--help -h)'{--help,-h}'[show help and exit]' \
+diff --git a/wgetpaste b/wgetpaste
+index fc0b559..d016515 100755
+--- a/wgetpaste
++++ b/wgetpaste
+@@ -559,6 +559,7 @@ Options:
+
+ -r, --raw show url for the raw paste (no syntax highlighting or html)
+ -t, --tee use tee to show what is being pasted
++ -q, --quiet show the url only
+ -v, --verbose show wget stderr output if no url is received
+ --completions emit output suitable for shell completions (only affects --list-*)
+ --debug be *very* verbose (implies -v)
+@@ -657,7 +658,7 @@ showexpirations() {
+ }
+
+ showurl() {
+- echo -n "Your ${2}paste can be seen here: " >&2
++ [[ $QUIET ]] || echo -n "Your ${2}paste can be seen here: " >&2
+ echo "$1"
+ [[ $XPASTE ]] && x_paste "$1" primary
+ [[ $XCLIPPASTE ]] && x_paste "$1" clipboard
+@@ -809,6 +810,9 @@ while [[ -n $1 ]]; do
+ -N | --no-ansi )
+ NOANSI=0
+ ;;
++ -q | --quiet)
++ QUIET=0
++ ;;
+ -r | --raw )
+ RAW=0
+ ;;
+--
+2.41.0
+
diff --git a/app-text/wgetpaste/wgetpaste-2.33-r3.ebuild b/app-text/wgetpaste/wgetpaste-2.33-r4.ebuild
index 89f63061351c..4a7f3ee27a86 100644
--- a/app-text/wgetpaste/wgetpaste-2.33-r3.ebuild
+++ b/app-text/wgetpaste/wgetpaste-2.33-r4.ebuild
@@ -23,6 +23,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.33-tests.patch
"${FILESDIR}"/${PN}-2.33-disable-sprunge.patch
"${FILESDIR}"/${PN}-2.33-add-paste-gentoo-zip.patch
+ "${FILESDIR}"/${PN}-2.33-added-quiet-flag.patch
)
src_prepare() {