summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-24 00:35:47 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-24 08:42:58 +0100
commitcc2dea922d791ace1c069f8380e2a84be4e04302 (patch)
tree10422480ff7e06a018abaca78d57eacc9cfe902b
parentdev-python/pyfakefs: Bump to 4.3.1 (diff)
downloadgentoo-cc2dea922d791ace1c069f8380e2a84be4e04302.tar.gz
gentoo-cc2dea922d791ace1c069f8380e2a84be4e04302.tar.bz2
gentoo-cc2dea922d791ace1c069f8380e2a84be4e04302.zip
dev-python/jsonpatch: Bump to 1.27
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jsonpatch/Manifest1
-rw-r--r--dev-python/jsonpatch/jsonpatch-1.27.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/jsonpatch/Manifest b/dev-python/jsonpatch/Manifest
index 2bb42a4ccf63..5c277f2b2912 100644
--- a/dev-python/jsonpatch/Manifest
+++ b/dev-python/jsonpatch/Manifest
@@ -1 +1,2 @@
DIST jsonpatch-1.26.tar.gz 24440 BLAKE2B 345831bd9a9fc1902d0959685ed2dbbc0bf04d191bbc78567d27283e9ae52f7e22f50e9f400461300d1c3388712afa51d4d6a2ddd0a06dbc0a1b576b02bfe807 SHA512 1ab25c8e091cd0b772062a8c448fee4772081d8bd715489b2f7a76e4c0bdff8b26dd38b26c3037cf9bdf8780b97e62a20b6a5bdc43f43af16fdae51d1291bf52
+DIST jsonpatch-1.27.tar.gz 26599 BLAKE2B b3481b4dd01d4fc6c2ad129141fb2b72d53d04744da54c1e4c989b2869113c15862d1ec5c84390758ad495ac36a9156f0e7b730ad091f96f6cb42fe96dde7fcd SHA512 297ca02d114e6b199bd516f69dca147fbe309f0a1b031046859271720645322607236f97b489c242575f7e1ad3cab0c68b1b7f11894c5af82be24013e376c0a4
diff --git a/dev-python/jsonpatch/jsonpatch-1.27.ebuild b/dev-python/jsonpatch/jsonpatch-1.27.ebuild
new file mode 100644
index 000000000000..7b86861b301e
--- /dev/null
+++ b/dev-python/jsonpatch/jsonpatch-1.27.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Apply JSON-Patches like http://tools.ietf.org/html/draft-pbryan-json-patch-04"
+HOMEPAGE="https://github.com/stefankoegl/python-json-patch"
+SRC_URI="https://github.com/stefankoegl/python-json-patch/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/python-json-patch-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/jsonpointer-1.9[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( ${RDEPEND} )
+"
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Tests of tests.py fail with ${EPYTHON}"
+ "${EPYTHON}" ext_tests.py || die "Tests of ext_tests.py fail with ${EPYTHON}"
+}