summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-06-05 12:40:29 -0400
committerMatt Turner <mattst88@gentoo.org>2023-06-05 12:46:34 -0400
commitcc3bf11f989c6001f1c7e63756562fe2be4f931a (patch)
treecb6ec88e912a86b6bedaa472208e71ed3091a7f3
parentdev-python/pyroute2: add 0.7.9 (diff)
downloadgentoo-cc3bf11f989c6001f1c7e63756562fe2be4f931a.tar.gz
gentoo-cc3bf11f989c6001f1c7e63756562fe2be4f931a.tar.bz2
gentoo-cc3bf11f989c6001f1c7e63756562fe2be4f931a.zip
gui-libs/vte-common: Version bump to 0.72.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--gui-libs/vte-common/Manifest1
-rw-r--r--gui-libs/vte-common/vte-common-0.72.2.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/gui-libs/vte-common/Manifest b/gui-libs/vte-common/Manifest
index 9dac5b2bd19e..b39f24252d73 100644
--- a/gui-libs/vte-common/Manifest
+++ b/gui-libs/vte-common/Manifest
@@ -1 +1,2 @@
DIST vte-0.72.1.tar.bz2 504271 BLAKE2B 8ab39ab8d491757ab9402ad4bfc10ca733427d2efe895204c0db580e44107a9ab005c29ce2e6934ae27e8da7c27e39d1173fe787ddb8569938a29697eed2e2e1 SHA512 a5655d2d2602183cbda1050003d7cf883e427c8e00976af4ee2685f43530d87169e31a3b9597133d14dffdc95f20f9ca1488186d8463997a2672510f5a95d145
+DIST vte-0.72.2.tar.bz2 503986 BLAKE2B dbd99a1288176482ebe2cee25a1ae508694a8b47739e9c93aa8f752bf50a1f7a6efd0944430550a73224ac92248e2c4738c51eec66a643efc03616dfa7c4b110 SHA512 0510677d67474fb04c69df0038b042d379ac8e1e89b77961e403b854e4a26b2063e93bcffd75ef0a0a324df077cf2f0a4ce51afa0ad0b1e66f707393590af274
diff --git a/gui-libs/vte-common/vte-common-0.72.2.ebuild b/gui-libs/vte-common/vte-common-0.72.2.ebuild
new file mode 100644
index 000000000000..5ea36a8149ca
--- /dev/null
+++ b/gui-libs/vte-common/vte-common-0.72.2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit gnome.org meson python-any-r1
+
+DESCRIPTION="Library providing a virtual terminal emulator widget"
+HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/VTE"
+
+# Once SIXEL support ships (0.66 or later), might need xterm license (but code might be considered upgraded to LGPL-3+)
+LICENSE="LGPL-3+ GPL-3+"
+SLOT="2.91" # vte_api_version in meson.build
+IUSE="systemd"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# Upstream is hostile and refuses to upload tarballs.
+SRC_URI="https://gitlab.gnome.org/GNOME/vte/-/archive/${PV}/vte-${PV}.tar.bz2"
+
+DEPEND="
+ || ( >=gui-libs/gtk-4.0.1:4 >=x11-libs/gtk+-3.24.22:3 )
+ >=dev-libs/fribidi-1.0.0
+ >=dev-libs/glib-2.60:2
+ >=x11-libs/pango-1.22.0
+ >=dev-libs/libpcre2-10.21
+ systemd? ( >=sys-apps/systemd-220:= )
+ sys-libs/zlib
+ x11-libs/pango
+"
+RDEPEND="
+ !<x11-libs/vte-0.70.0:2.91
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/vte-${PV}"
+
+src_prepare() {
+ default
+ use elibc_musl && eapply "${FILESDIR}"/${PN}-0.70.0-musl-W_EXITCODE.patch
+}
+
+src_configure() {
+ local emesonargs=(
+ -Da11y=false
+ -Ddebugg=false
+ -Ddocs=false
+ -Dgir=false
+ -Dfribidi=true # pulled in by pango anyhow
+ -Dglade=false
+ -Dgnutls=false
+ -Dgtk3=false
+ -Dgtk4=false
+ -Dicu=false
+ $(meson_use systemd _systemd)
+ -Dvapi=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ exeinto /usr/libexec/
+ doexe "${BUILD_DIR}"/src/vte-urlencode-cwd
+ insinto /etc/profile.d/
+ newins "${BUILD_DIR}"/src/vte.sh vte-${SLOT}.sh
+ newins "${BUILD_DIR}"/src/vte.csh vte-${SLOT}.csh
+ if use systemd; then
+ insinto /usr/lib/systemd/user/vte-spawn-.scode.d/
+ newins "${S}"/src/vte-spawn-.scope.conf defaults.conf
+ fi
+ einstalldocs
+}