summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-19 09:30:31 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-19 09:40:54 +0200
commitcc4f15b934bd0574b1e58eda87ec9d1672625243 (patch)
tree8d0a161c55234bb3c264fb2bb24b22be41548616
parentdev-python/mechanize: Bump to 0.4.7 (diff)
downloadgentoo-cc4f15b9.tar.gz
gentoo-cc4f15b9.tar.bz2
gentoo-cc4f15b9.zip
dev-python/zeroconf: Bump to 0.36.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/zeroconf/Manifest1
-rw-r--r--dev-python/zeroconf/zeroconf-0.36.5.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index 4703e84b97a7..ede926083a7b 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -1,2 +1,3 @@
DIST python-zeroconf-0.35.1.gh.tar.gz 127099 BLAKE2B dc09dadaeaac64d8517de407ddcfffc4152e366430c492d4ab562c56afa3264c33a26373f249bbddd969bb28dbc5c1b7513e59c0ebb728c12a77fb9d428e4f0a SHA512 27386cd425928821080c9c6fd2babdcfc001cc4583ef4c699169e3818f6bb8536f712cf7959e6003a6aaf40e85b5337a8a5abcfdf686455dee577cfa61270fb7
DIST python-zeroconf-0.36.4.gh.tar.gz 128860 BLAKE2B ee6d02b583933404b6a1945235c1708e74211ae985a8c8e493098c59fe7003ef09223a87f9db87c78a22d0c1823748ea9f3aa1ca106a340d5df5a3ca6cfcb0bf SHA512 b1bfba10f374d006979ab0a626b9c3e9c0be25b07ad0f5242c463507b221cabfe11d18b02b29edc68f14b838b738b9a1265445fb8988e3243889454f17b3d7f3
+DIST python-zeroconf-0.36.5.gh.tar.gz 129395 BLAKE2B 3e62da5f38bd0648ed300c2ecea712121cc3b8707871cf3de325cce0348b5972e538e70d74acfccb8540fa8253db992670902c13ac4b81928a47df4fa27d248e SHA512 ef51541da2c8d6703644750572d55093230ccf776b1a5bd67e0a6fa0f5f9762056b4cd7124e88efbee27ca768bbdf3e54fd051432d252f45376b7354bab4c50d
diff --git a/dev-python/zeroconf/zeroconf-0.36.5.ebuild b/dev-python/zeroconf/zeroconf-0.36.5.ebuild
new file mode 100644
index 000000000000..b416d399c1d2
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.36.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=python-zeroconf-${PV}
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/jstasiak/python-zeroconf/
+ https://pypi.org/project/zeroconf/"
+SRC_URI="
+ https://github.com/jstasiak/python-zeroconf/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+ tests/test_core.py::Framework::test_launch_and_close_v4_v6
+ tests/test_core.py::Framework::test_launch_and_close_v6_only
+ tests/services/test_types.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+)