summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuigi 'Comio' Mantellini <luigi.mantellini@gmail.com>2019-10-14 15:08:03 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-10-21 17:08:18 +0300
commitcc6074c8e8cef8cab8836486e859a69b3258428b (patch)
treef0c2f6cdbfc0ecbaa2c7ffb596b071d7785f8550
parentsys-apps/dstat: version bump to 0.7.4 (diff)
downloadgentoo-cc6074c8e8cef8cab8836486e859a69b3258428b.tar.gz
gentoo-cc6074c8e8cef8cab8836486e859a69b3258428b.tar.bz2
gentoo-cc6074c8e8cef8cab8836486e859a69b3258428b.zip
dev-python/node-semver: bump to 0.7.0
Closes: https://bugs.gentoo.org/696648 Signed-off-by: Luigi 'Comio' Mantellini <luigi.mantellini@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/13302 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-python/node-semver/Manifest1
-rw-r--r--dev-python/node-semver/node-semver-0.7.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/node-semver/Manifest b/dev-python/node-semver/Manifest
index 9051017fbadd..288df154d23c 100644
--- a/dev-python/node-semver/Manifest
+++ b/dev-python/node-semver/Manifest
@@ -1,2 +1,3 @@
DIST node-semver-0.2.0.tar.gz 10236 BLAKE2B f4f48761a0086b8a2e79307427b4dc93954362452f653042582024cee593b4b7fefb1a14d3d4ea6832255209b054c9bdb05b02cb101af1e359a1266c472c5149 SHA512 7c636d94a262723c5e50123433c9c7af38424c46711c1b8e001931b242fc9703a084a0426b75e6884104a4adc6104a298355bf3c1604b9cae0ddab7d5f11b430
DIST node-semver-0.6.1.tar.gz 17952 BLAKE2B f7d48f7d0373acdad56ef6745f09653163f3bcfbed26820ff77205d7bb479b0c9debfd79f719d3eb973d3cec06b0bac3773f06351712c274f90a2dcf5c658694 SHA512 d1f406d6e82f02c3e0eb0f4e1506279b00e7f31875f45bfbd7f87e6777b46676003bb7b39241bdeae616c6506dd85c60e61217460c55dd5079ea87cd818cd6bc
+DIST node-semver-0.7.0.tar.gz 18090 BLAKE2B 669da955b62c35be1a0fccbdce8c66c9de915c5498052858f9f0ebe6a07109947314c904b2077b4306b8fea9f1d0747ab7dcb63a803b00555320e44ea0a59081 SHA512 9e11af16ce7a9a7f2aacd77ff14c8aa574e62bc27f902860b97fda5cc8ee19f54118e90ca39241741da657b87ec2653239b0c4255570ffe4d1ad49e2c9484e74
diff --git a/dev-python/node-semver/node-semver-0.7.0.ebuild b/dev-python/node-semver/node-semver-0.7.0.ebuild
new file mode 100644
index 000000000000..38da8d9ff050
--- /dev/null
+++ b/dev-python/node-semver/node-semver-0.7.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python version of node-semver, the semantic versioner for npm"
+HOMEPAGE="
+ https://pypi.org/project/node-semver/
+ https://github.com/podhmo/python-semver
+ https://github.com/npm/node-semver
+"
+# Tests are currently missing from PyPI tarballs
+# https://github.com/podhmo/python-semver/pull/31
+SRC_URI="https://github.com/podhmo/python-semver/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+S="${WORKDIR}/python-semver-${PV}"
+
+python_test() {
+ # Ignore 2 tests that fail with Python 2
+ # https://github.com/podhmo/python-semver/issues/30
+ pytest -vv --ignore semver/tests/test_passing_bytes.py \
+ || die "tests failed with ${EPYTHON}"
+}