summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-09-02 11:24:50 +0100
committerMarek Szuba <marecki@gentoo.org>2022-09-02 11:52:08 +0100
commitcc651686afe763c72eaf2bd0fb122e624e134275 (patch)
treeab5f654bc8fce01e4114fcb100c62de7f2d48697
parentapp-admin/ansible: enable py3.11 (diff)
downloadgentoo-cc651686.tar.gz
gentoo-cc651686.tar.bz2
gentoo-cc651686.zip
net-libs/xrootd: drop 5.0.3-r1
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--net-libs/xrootd/Manifest1
-rw-r--r--net-libs/xrootd/xrootd-5.0.3-r1.ebuild117
2 files changed, 0 insertions, 118 deletions
diff --git a/net-libs/xrootd/Manifest b/net-libs/xrootd/Manifest
index bb0210d32398..82d24fcfcf67 100644
--- a/net-libs/xrootd/Manifest
+++ b/net-libs/xrootd/Manifest
@@ -1,2 +1 @@
-DIST xrootd-5.0.3.tar.gz 2766694 BLAKE2B 1fe7743de4d09c95257c3d761c2056024ba3ba59b7cd86b5926f2d32cc2f85dcd0af69e6e5969967591a2bba293902b757395e0f9375cbbbb39577eed9e450eb SHA512 e085af48e4196a44e9ebd63bf1234cf4401f158d23d03ffb38fcfe43284d025abe6c0b5e46b2808b28f300b933ff12523f64ac2d86d3f344aa2e0aea95e30cb0
DIST xrootd-5.4.3.tar.gz 3182127 BLAKE2B ed3f6a943167eafb5f6d7f78ca34f44c9a18b5ed672a4e622acb1e6e6997bd21756a30bf24f0b799ab4f16e7e1fb3f61a042f4e5e00f965b898fc5a287bf995a SHA512 189ec8e20901fd07093494187502e031a60d4ade22af33067313fad7a1bf6a6feb5c5d9d59d3a86d13a6a767e5a93cf4836da02e9cae11c81ccac07199898d72
diff --git a/net-libs/xrootd/xrootd-5.0.3-r1.ebuild b/net-libs/xrootd/xrootd-5.0.3-r1.ebuild
deleted file mode 100644
index 63d03a9265a8..000000000000
--- a/net-libs/xrootd/xrootd-5.0.3-r1.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-# Upstream does not support the building of Python bindings
-# via CMake for more than one implementation at a time.
-inherit cmake python-single-r1
-
-DESCRIPTION="Extended ROOT remote file server"
-HOMEPAGE="http://xrootd.org/"
-SRC_URI="http://xrootd.org/download/v${PV}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples fuse http kerberos python readline ssl test"
-RESTRICT="!test? ( test )"
-
-CDEPEND="acct-group/xrootd
- acct-user/xrootd
- sys-libs/zlib
- virtual/libcrypt:=
- fuse? ( sys-fs/fuse:= )
- kerberos? ( virtual/krb5 )
- python? ( ${PYTHON_DEPS} )
- readline? ( sys-libs/readline:0= )
- ssl? ( <dev-libs/openssl-3.0.0:0= )
-"
-DEPEND="${CDEPEND}"
-BDEPEND="
- doc? (
- app-doc/doxygen[dot]
- python? ( dev-python/sphinx )
- )
- test? ( dev-util/cppunit )
-"
-RDEPEND="${CDEPEND}
- dev-lang/perl
-"
-REQUIRED_USE="
- http? ( kerberos ssl )
- python? ( ${PYTHON_REQUIRED_USE} )
-"
-
-PATCHES=( "${FILESDIR}"/xrootd-4.8.3-crc32.patch )
-
-# xrootd plugins are not intended to be linked with,
-# they are to be loaded at runtime by xrootd,
-# see https://github.com/xrootd/xrootd/issues/447
-QA_SONAME="/usr/lib.*/libXrd.*-$(ver_cut 1)\.so
- /usr/lib.*/libXrdClTests\.so"
-
-pkg_setup() {
- use python && python_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_CRYPTO=$(usex ssl)
- -DENABLE_FUSE=$(usex fuse)
- -DENABLE_HTTP=$(usex http)
- -DENABLE_KRB5=$(usex kerberos)
- -DENABLE_PYTHON=$(usex python)
- -DENABLE_READLINE=$(usex readline)
- -DENABLE_TESTS=$(usex test)
- )
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- if use doc; then
- doxygen Doxyfile || die
- if use python; then
- emake -C bindings/python/docs html
- fi
- fi
-}
-
-src_install() {
- use doc && HTML_DOCS=( doxydoc/html/. )
- dodoc docs/ReleaseNotes.txt
- cmake_src_install
- find "${D}" \( -iname '*.md5' -o -iname '*.map' \) -delete || die
-
- # base configs
- insinto /etc/xrootd
- doins packaging/common/*.cfg
-
- fowners root:xrootd /etc/xrootd
- keepdir /var/log/xrootd
- fowners xrootd:xrootd /var/log/xrootd
-
- local i
- for i in cmsd frm_purged frm_xfrd xrootd; do
- newinitd "${FILESDIR}"/${i}.initd ${i}
- done
- # all daemons MUST use single master config file
- newconfd "${FILESDIR}"/xrootd.confd xrootd
-
- if use python; then
- python_optimize "${D}/$(python_get_sitedir)"
-
- if use doc; then
- docinto python
- docompress -x "/usr/share/doc/${PF}/python/html"
- dodoc -r bindings/python/docs/build/html
- fi
- if use examples; then
- docinto python
- dodoc -r bindings/python/examples
- fi
- fi
-}