summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-01-01 07:31:16 +0100
committerHans de Graaff <graaff@gentoo.org>2018-01-01 07:31:16 +0100
commitcc9fb16e3dde592514cfc7ea3e475c27d50f2604 (patch)
tree2c6fc087bd2324edf789dde84d37a7da27caf22a
parentdev-ruby/xpath: cleanup (diff)
downloadgentoo-cc9fb16e.tar.gz
gentoo-cc9fb16e.tar.bz2
gentoo-cc9fb16e.zip
dev-ruby/xpath: add 3.0.0
Package-Manager: Portage-2.3.13, Repoman-2.3.3
-rw-r--r--dev-ruby/xpath/Manifest1
-rw-r--r--dev-ruby/xpath/xpath-3.0.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/xpath/Manifest b/dev-ruby/xpath/Manifest
index 4221d64cd780..35869a51dd0a 100644
--- a/dev-ruby/xpath/Manifest
+++ b/dev-ruby/xpath/Manifest
@@ -1 +1,2 @@
DIST xpath-2.1.0.gem 16896 BLAKE2B b8dc2b0e207c666446ba5948f6e37c71f410d8a5a027dddd17d5ccb2fa8b0c32f274a34cc144a2380b22266248acad288828114a755d4f04c2a1caeec6ee55e3 SHA512 50d80cac3fd65cbd211d3a87b8844a6607b14c841a1a5609e2370c3624daf719b937a61e526bf31aedee13346802d6bbb721d58bda2bef9c564c187b28bb90e2
+DIST xpath-3.0.0.gem 13824 BLAKE2B 19b41febf466a8bd72cab071fd8e68844c3bf1b2c06ce4aefe6c5a08e4f57ec8f1fd8478c60076a7e6967a85faf49680950f66ab9ebf1d2c47326da40e1f1847 SHA512 fd1e8cfff11e8c14efb1ad2cabb9a0a3bc3d79d40b61264c524ff4524c5e7b9ff86de0746f4530fe7501f5e5e1683cb87c4a479f5e67deb7d8f93ed552ec78d6
diff --git a/dev-ruby/xpath/xpath-3.0.0.ebuild b/dev-ruby/xpath/xpath-3.0.0.ebuild
new file mode 100644
index 000000000000..a0d9eb988afc
--- /dev/null
+++ b/dev-ruby/xpath/xpath-3.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="XPath is a Ruby DSL around a subset of XPath 1.0"
+HOMEPAGE="https://github.com/jnicklas/xpath"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+SLOT="3"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/nokogiri-1.8:0"
+
+all_ruby_prepare() {
+ sed -i -e '/\(bundler\|pry\)/d' spec/spec_helper.rb || die
+}