summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-27 08:01:15 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-27 08:01:15 +0200
commitccae444467b80f241542d80b765233f0b67aec53 (patch)
treecc9092bbb8cc6d3fe548dd564eeb465131314cd8
parentdev-python/sphinx: Remove old (diff)
downloadgentoo-ccae4444.tar.gz
gentoo-ccae4444.tar.bz2
gentoo-ccae4444.zip
dev-python/urllib3: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/urllib3/Manifest1
-rw-r--r--dev-python/urllib3/urllib3-1.26.10.ebuild78
2 files changed, 0 insertions, 79 deletions
diff --git a/dev-python/urllib3/Manifest b/dev-python/urllib3/Manifest
index 127f03eb5d61..18b1efc3d4b6 100644
--- a/dev-python/urllib3/Manifest
+++ b/dev-python/urllib3/Manifest
@@ -1,3 +1,2 @@
-DIST urllib3-1.26.10.tar.gz 297854 BLAKE2B 2523bc197ed9720e2bd011ffa46a46605cab902d66b245cb5229e15e90ac5bac990851d6cb9b6aa2dd5682da2639af7cd8e3c8c27f1210e5ca0c7c10498babd3 SHA512 76c1cc9420c267986c7775a9d9eadfd08e980643c2da16602f755e11a274ffbbf1813f30245fb0d84ee3a99bb3aa33b98893f285cabec8dd4aee1304420cb15b
DIST urllib3-1.26.11.tar.gz 299255 BLAKE2B bf4d5f0b9f8a95c825b9f8fd963a1dc46688123641c3198812dedc11155f445f75ca321e3e283b649bc30cda8de497d0fb88298d6ad41660d91b8843121e50a2 SHA512 d2cc0f57469b640147f2087e2844a7c2c45e5a374ad0f28c1639d9a38ff6d6760f65b9b3187409cee29782d854468a1e4bc1b20d96e010fdd1fd4213bf1cd924
DIST urllib3-1.26.12.tar.gz 299806 BLAKE2B 17c1f02382101b5a44fbc456344befe671c9579f6208ea307866ae0e2fabbe017fdd4b751a6053a6d014bf007f114ca4fc81e2149c9814ab5bef057ffcbce2d0 SHA512 c34bc2cb92ff5fb4e27948b6b8bf286d1f3993d8e399a7dc99e8c1cb07b364f16f9c8d6fc3e5e22e6f2d9285454a945174a9a1de3cb0fcf08e673ba316bc5469
diff --git a/dev-python/urllib3/urllib3-1.26.10.ebuild b/dev-python/urllib3/urllib3-1.26.10.ebuild
deleted file mode 100644
index 9f87338afe5a..000000000000
--- a/dev-python/urllib3/urllib3-1.26.10.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-PYTHON_REQ_USE="ssl(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP library with thread-safe connection pooling, file post, and more"
-HOMEPAGE="
- https://github.com/urllib3/urllib3/
- https://pypi.org/project/urllib3/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="brotli test"
-RESTRICT="!test? ( test )"
-
-# dev-python/{pyopenssl,cryptography,idna,certifi} are optional runtime
-# dependencies. Do not add them to RDEPEND. They should be unnecessary with
-# modern versions of python (>= 3.2).
-RDEPEND="
- >=dev-python/PySocks-1.5.8[${PYTHON_USEDEP}]
- <dev-python/PySocks-2.0[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- brotli? ( dev-python/brotlicffi[${PYTHON_USEDEP}] )
-"
-BDEPEND="
- test? (
- $(python_gen_cond_dep "
- ${RDEPEND}
- dev-python/brotlicffi[\${PYTHON_USEDEP}]
- dev-python/mock[\${PYTHON_USEDEP}]
- dev-python/pytest[\${PYTHON_USEDEP}]
- dev-python/pytest-freezegun[\${PYTHON_USEDEP}]
- >=dev-python/trustme-0.5.3[\${PYTHON_USEDEP}]
- >=www-servers/tornado-4.2.1[\${PYTHON_USEDEP}]
- " python3_{8..11})
- )
-"
-
-src_prepare() {
- distutils-r1_src_prepare
-
- # unbundle urllib3
- rm src/urllib3/packages/six.py || die
- find -name '*.py' -exec sed -i \
- -e 's:\([.]*\|urllib3\.\)\?packages\.six:six:g' \
- -e 's:from \([.]*\|urllib3\.\)\?packages import six:import six:g' \
- {} + || die
-}
-
-python_test() {
- local -x CI=1
- # FIXME: get tornado ported
- # please keep in sync with BDEPEND!
- if ! has "${EPYTHON}" python3.{8..11}; then
- einfo "Skipping tests on ${EPYTHON}"
- return
- fi
-
- local EPYTEST_DESELECT=(
- # unstable (relies on warning count)
- test/with_dummyserver/test_proxy_poolmanager.py::TestHTTPProxyManager::test_proxy_verified_warning
- )
- has "${EPYTHON}" python3.{8..10} && EPYTEST_DESELECT+=(
- test/contrib/test_pyopenssl.py::TestPyOpenSSLHelpers::test_get_subj_alt_name
- )
-
- epytest
-}